p PatchFirst

CVE-2026-26974

CVE-2026-26974 · Sylde has Improper Control of Generation of Code

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Slyde is a program that creates animated presentations from XML. In versions 0.0.4 and below, Node.js automatically imports **/*.plugin.{js,mjs} files including those from node_modules, so any malicious package with a .plugin.js file can execute arbitrary code when installed or required. All projects using this loading behavior are affected, especially those installing untrusted packages. This issue has been fixed in version 0.0.5. To workaround this issue, users can audit and restrict which packages are installed in node_modules.

CVSS 7.6 · Hoch · EPSS 0,6% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • slyde

    Softwareversionen
    • < 0.0.5: Betroffen

    Keine Korrektur veröffentlicht

  • @tygo-van-den-hurk/slyde npm

    Betroffene Versionsbereiche
    • SEMVER: < 0.0.5

    Auf 0.0.5 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →