p PatchFirst

CVE-2026-2808

CVE-2026-2808 · Consul vulnerable to arbitrary file reads through the vault kubernetes authentication provider

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

HashiCorp Consul and Consul Enterprise 1.18.20 up to 1.21.10 and 1.22.4 are vulnerable to arbitrary file read when configured with Kubernetes authentication. This vulnerability, CVE-2026-2808, is fixed in Consul 1.18.21, 1.21.11 and 1.22.5.

CVSS 6.8 · Media · EPSS 0,5% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • consul

    Versiones
    • ≥ 0, < 1.22.5: Afectada (semver)

    Actualiza a 1.22.5

  • consul enterprise

    Versiones
    • ≥ 0, < 1.22.5: Afectada; ≥ 1.21.11: No afectada; ≥ 1.18.21: No afectada (semver)

    Actualiza a 1.18.21

  • consul Debian:11

    Versiones
    • 1.10.12+dfsg1-1
    • 1.8.7+dfsg1-2
    • 1.8.7+dfsg1-3
    • 1.8.7+dfsg1-4
    • 1.8.7+dfsg1-5
    • 1.8.7+dfsg1-6
    • 1.9.17+dfsg2-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • consul Ubuntu:18.04:LTS

    Versiones
    • 0.6.4~dfsg-3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • consul Ubuntu:20.04:LTS

    Versiones
    • 1.0.7~dfsg1-5ubuntu1
    • 1.4.4~dfsg1-2ubuntu2
    • 1.5.2+dfsg1-6
    • 1.5.2+dfsg1-10
    • 1.5.2+dfsg1-12
    • 1.5.2+dfsg2-14
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • consul Ubuntu:22.04:LTS

    Versiones
    • 1.7.4+dfsg1-1
    • 1.8.7+dfsg1-3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →