CVE-2026-2808
CVE-2026-2808 · Consul vulnerable to arbitrary file reads through the vault kubernetes authentication provider
This page contains facts from public vulnerability sources. Check the original advisory before updating.
HashiCorp Consul and Consul Enterprise 1.18.20 up to 1.21.10 and 1.22.4 are vulnerable to arbitrary file read when configured with Kubernetes authentication. This vulnerability, CVE-2026-2808, is fixed in Consul 1.18.21, 1.21.11 and 1.22.5.
CVSS 6.8 · Medium · EPSS 0.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
consul
- Versions
- ≥ 0, < 1.22.5: Affected (semver)
Update to 1.22.5
consul enterprise
- Versions
- ≥ 0, < 1.22.5: Affected; ≥ 1.21.11: Not affected; ≥ 1.18.21: Not affected (semver)
Update to 1.18.21
consul Debian:11
- Versions
- 1.10.12+dfsg1-1
- 1.8.7+dfsg1-2
- 1.8.7+dfsg1-3
- 1.8.7+dfsg1-4
- 1.8.7+dfsg1-5
- 1.8.7+dfsg1-6
- 1.9.17+dfsg2-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
consul Ubuntu:18.04:LTS
- Versions
- 0.6.4~dfsg-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
consul Ubuntu:20.04:LTS
- Versions
- 1.0.7~dfsg1-5ubuntu1
- 1.4.4~dfsg1-2ubuntu2
- 1.5.2+dfsg1-6
- 1.5.2+dfsg1-10
- 1.5.2+dfsg1-12
- 1.5.2+dfsg2-14
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
consul Ubuntu:22.04:LTS
- Versions
- 1.7.4+dfsg1-1
- 1.8.7+dfsg1-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published