p PatchFirst

CVE-2026-2808

CVE-2026-2808 · Consul vulnerable to arbitrary file reads through the vault kubernetes authentication provider

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

HashiCorp Consul and Consul Enterprise 1.18.20 up to 1.21.10 and 1.22.4 are vulnerable to arbitrary file read when configured with Kubernetes authentication. This vulnerability, CVE-2026-2808, is fixed in Consul 1.18.21, 1.21.11 and 1.22.5.

CVSS 6.8 · Mittel · EPSS 0,5% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • consul

    Softwareversionen
    • ≥ 0, < 1.22.5: Betroffen (semver)

    Auf 1.22.5 aktualisieren

  • consul enterprise

    Softwareversionen
    • ≥ 0, < 1.22.5: Betroffen; ≥ 1.21.11: Nicht betroffen; ≥ 1.18.21: Nicht betroffen (semver)

    Auf 1.18.21 aktualisieren

  • consul Debian:11

    Softwareversionen
    • 1.10.12+dfsg1-1
    • 1.8.7+dfsg1-2
    • 1.8.7+dfsg1-3
    • 1.8.7+dfsg1-4
    • 1.8.7+dfsg1-5
    • 1.8.7+dfsg1-6
    • 1.9.17+dfsg2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • consul Ubuntu:18.04:LTS

    Softwareversionen
    • 0.6.4~dfsg-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • consul Ubuntu:20.04:LTS

    Softwareversionen
    • 1.0.7~dfsg1-5ubuntu1
    • 1.4.4~dfsg1-2ubuntu2
    • 1.5.2+dfsg1-6
    • 1.5.2+dfsg1-10
    • 1.5.2+dfsg1-12
    • 1.5.2+dfsg2-14
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • consul Ubuntu:22.04:LTS

    Softwareversionen
    • 1.7.4+dfsg1-1
    • 1.8.7+dfsg1-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →