CVE-2026-30929
CVE-2026-30929 · ImageMagick has a stack buffer overflow in MagnifyImage
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to versions 7.1.2-16 and 6.9.13-41, MagnifyImage uses a fixed-size stack buffer. When using a specific image it is possible to overflow this buffer and corrupt the stack. This vulnerability is fixed in 7.1.2-16 and 6.9.13-41.
CVSS 7.7 · Alta · EPSS 0,1% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
imagemagick
- Versiones
- >= 7.0.0, < 7.1.2-16: Afectada
- < 6.9.13-41: Afectada
Sin corrección publicada
imagemagick Debian:13
- Versiones
- 8:7.1.1.43+dfsg1-1
- 8:7.1.1.43+dfsg1-1+deb13u1
- 8:7.1.1.43+dfsg1-1+deb13u2
- 8:7.1.1.43+dfsg1-1+deb13u3
- 8:7.1.1.43+dfsg1-1+deb13u4
- 8:7.1.1.43+dfsg1-1+deb13u5
- 8:7.1.1.43+dfsg1-1+deb13u6
- Intervalos de versiones afectados
- ECOSYSTEM: < 8:7.1.1.43+dfsg1-1+deb13u7
Actualiza a 8:7.1.1.43+dfsg1-1+deb13u7
imagemagick Debian:14
- Versiones
- 8:7.1.1.43+dfsg1-1
- 8:7.1.1.46+dfsg1-1
- 8:7.1.1.47+dfsg1-1
- 8:7.1.1.47+dfsg1-2
- 8:7.1.2.1+dfsg1-1
- 8:7.1.2.12+dfsg1-1
- 8:7.1.2.13+dfsg1-1
- 8:7.1.2.15+dfsg1-1
- 8:7.1.2.15+dfsg1-2
- 8:7.1.2.3+dfsg1-1
- 8:7.1.2.7+dfsg1-1
- 8:7.1.2.8+dfsg1-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 8:7.1.2.16+dfsg1-1
Actualiza a 8:7.1.2.16+dfsg1-1
imagemagick Ubuntu:25.10
- Versiones
- 8:7.1.1.43+dfsg1-1
- 8:7.1.1.43+dfsg1-1ubuntu1
- 8:7.1.1.43+dfsg1-1ubuntu2
- 8:7.1.2.3+dfsg1-1
- 8:7.1.2.3+dfsg1-1ubuntu0.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
imagemagick Ubuntu:Pro:26.04:LTS
- Versiones
- 8:7.1.2.3+dfsg1-1
- 8:7.1.2.8+dfsg1-1
- 8:7.1.2.12+dfsg1-1
- 8:7.1.2.13+dfsg1-1
- 8:7.1.2.15+dfsg1-1
- 8:7.1.2.16+dfsg1-1
- 8:7.1.2.18+dfsg1-1
- 8:7.1.2.18+dfsg1-1ubuntu0.1~esm1
- 8:7.1.2.18+dfsg1-1ubuntu0.1~esm2
- 8:7.1.2.18+dfsg1-1ubuntu0.1~esm3
- 8:7.1.2.18+dfsg1-1ubuntu0.1~esm4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada