CVE-2026-30929
CVE-2026-30929 · ImageMagick has a stack buffer overflow in MagnifyImage
This page contains facts from public vulnerability sources. Check the original advisory before updating.
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to versions 7.1.2-16 and 6.9.13-41, MagnifyImage uses a fixed-size stack buffer. When using a specific image it is possible to overflow this buffer and corrupt the stack. This vulnerability is fixed in 7.1.2-16 and 6.9.13-41.
CVSS 7.7 · High · EPSS 0.1% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
imagemagick
- Versions
- >= 7.0.0, < 7.1.2-16: Affected
- < 6.9.13-41: Affected
No fix published
imagemagick Debian:13
- Versions
- 8:7.1.1.43+dfsg1-1
- 8:7.1.1.43+dfsg1-1+deb13u1
- 8:7.1.1.43+dfsg1-1+deb13u2
- 8:7.1.1.43+dfsg1-1+deb13u3
- 8:7.1.1.43+dfsg1-1+deb13u4
- 8:7.1.1.43+dfsg1-1+deb13u5
- 8:7.1.1.43+dfsg1-1+deb13u6
- Affected ranges
- ECOSYSTEM: < 8:7.1.1.43+dfsg1-1+deb13u7
Update to 8:7.1.1.43+dfsg1-1+deb13u7
imagemagick Debian:14
- Versions
- 8:7.1.1.43+dfsg1-1
- 8:7.1.1.46+dfsg1-1
- 8:7.1.1.47+dfsg1-1
- 8:7.1.1.47+dfsg1-2
- 8:7.1.2.1+dfsg1-1
- 8:7.1.2.12+dfsg1-1
- 8:7.1.2.13+dfsg1-1
- 8:7.1.2.15+dfsg1-1
- 8:7.1.2.15+dfsg1-2
- 8:7.1.2.3+dfsg1-1
- 8:7.1.2.7+dfsg1-1
- 8:7.1.2.8+dfsg1-1
- Affected ranges
- ECOSYSTEM: < 8:7.1.2.16+dfsg1-1
Update to 8:7.1.2.16+dfsg1-1
imagemagick Ubuntu:25.10
- Versions
- 8:7.1.1.43+dfsg1-1
- 8:7.1.1.43+dfsg1-1ubuntu1
- 8:7.1.1.43+dfsg1-1ubuntu2
- 8:7.1.2.3+dfsg1-1
- 8:7.1.2.3+dfsg1-1ubuntu0.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
imagemagick Ubuntu:Pro:26.04:LTS
- Versions
- 8:7.1.2.3+dfsg1-1
- 8:7.1.2.8+dfsg1-1
- 8:7.1.2.12+dfsg1-1
- 8:7.1.2.13+dfsg1-1
- 8:7.1.2.15+dfsg1-1
- 8:7.1.2.16+dfsg1-1
- 8:7.1.2.18+dfsg1-1
- 8:7.1.2.18+dfsg1-1ubuntu0.1~esm1
- 8:7.1.2.18+dfsg1-1ubuntu0.1~esm2
- 8:7.1.2.18+dfsg1-1ubuntu0.1~esm3
- 8:7.1.2.18+dfsg1-1ubuntu0.1~esm4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published