CVE-2026-30929
CVE-2026-30929 · ImageMagick has a stack buffer overflow in MagnifyImage
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to versions 7.1.2-16 and 6.9.13-41, MagnifyImage uses a fixed-size stack buffer. When using a specific image it is possible to overflow this buffer and corrupt the stack. This vulnerability is fixed in 7.1.2-16 and 6.9.13-41.
CVSS 7.7 · Hoch · EPSS 0,1% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
imagemagick
- Softwareversionen
- >= 7.0.0, < 7.1.2-16: Betroffen
- < 6.9.13-41: Betroffen
Keine Korrektur veröffentlicht
imagemagick Debian:13
- Softwareversionen
- 8:7.1.1.43+dfsg1-1
- 8:7.1.1.43+dfsg1-1+deb13u1
- 8:7.1.1.43+dfsg1-1+deb13u2
- 8:7.1.1.43+dfsg1-1+deb13u3
- 8:7.1.1.43+dfsg1-1+deb13u4
- 8:7.1.1.43+dfsg1-1+deb13u5
- 8:7.1.1.43+dfsg1-1+deb13u6
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8:7.1.1.43+dfsg1-1+deb13u7
Auf 8:7.1.1.43+dfsg1-1+deb13u7 aktualisieren
imagemagick Debian:14
- Softwareversionen
- 8:7.1.1.43+dfsg1-1
- 8:7.1.1.46+dfsg1-1
- 8:7.1.1.47+dfsg1-1
- 8:7.1.1.47+dfsg1-2
- 8:7.1.2.1+dfsg1-1
- 8:7.1.2.12+dfsg1-1
- 8:7.1.2.13+dfsg1-1
- 8:7.1.2.15+dfsg1-1
- 8:7.1.2.15+dfsg1-2
- 8:7.1.2.3+dfsg1-1
- 8:7.1.2.7+dfsg1-1
- 8:7.1.2.8+dfsg1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8:7.1.2.16+dfsg1-1
Auf 8:7.1.2.16+dfsg1-1 aktualisieren
imagemagick Ubuntu:25.10
- Softwareversionen
- 8:7.1.1.43+dfsg1-1
- 8:7.1.1.43+dfsg1-1ubuntu1
- 8:7.1.1.43+dfsg1-1ubuntu2
- 8:7.1.2.3+dfsg1-1
- 8:7.1.2.3+dfsg1-1ubuntu0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
imagemagick Ubuntu:Pro:26.04:LTS
- Softwareversionen
- 8:7.1.2.3+dfsg1-1
- 8:7.1.2.8+dfsg1-1
- 8:7.1.2.12+dfsg1-1
- 8:7.1.2.13+dfsg1-1
- 8:7.1.2.15+dfsg1-1
- 8:7.1.2.16+dfsg1-1
- 8:7.1.2.18+dfsg1-1
- 8:7.1.2.18+dfsg1-1ubuntu0.1~esm1
- 8:7.1.2.18+dfsg1-1ubuntu0.1~esm2
- 8:7.1.2.18+dfsg1-1ubuntu0.1~esm3
- 8:7.1.2.18+dfsg1-1ubuntu0.1~esm4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht