CVE-2026-31841
CVE-2026-31841 · Raw exposure of database statements in Hyperterse MCP search tool
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Hyperterse is a tool-first MCP framework for building AI-ready backend surfaces from declarative config. Prior to v2.2.0, the search tool allows LLMs to search for tools using natural language. While returning results, Hyperterse also returned the raw SQL queries, exposing statements which were supposed to be executed under the hood, and protected from being displayed publicly. This issue has been fixed as of v2.2.0.
CVSS 6.5 · Media · EPSS 0,2% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: node
Productos y versiones afectados
hyperterse
- Versiones
- >= 2.0.0, < 2.2.0: Afectada
Sin corrección publicada
hyperterse npm
- Intervalos de versiones afectados
- SEMVER: ≥ 2.0.0, < 2.2.0
Actualiza a 2.2.0