CVE-2026-31841
CVE-2026-31841 · Raw exposure of database statements in Hyperterse MCP search tool
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Hyperterse is a tool-first MCP framework for building AI-ready backend surfaces from declarative config. Prior to v2.2.0, the search tool allows LLMs to search for tools using natural language. While returning results, Hyperterse also returned the raw SQL queries, exposing statements which were supposed to be executed under the hood, and protected from being displayed publicly. This issue has been fixed as of v2.2.0.
CVSS 6.5 · Mittel · EPSS 0,2% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: node
Betroffene Produkte und Versionen
hyperterse
- Softwareversionen
- >= 2.0.0, < 2.2.0: Betroffen
Keine Korrektur veröffentlicht
hyperterse npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 2.0.0, < 2.2.0
Auf 2.2.0 aktualisieren