p PatchFirst

CVE-2026-31841

CVE-2026-31841 · Raw exposure of database statements in Hyperterse MCP search tool

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Hyperterse is a tool-first MCP framework for building AI-ready backend surfaces from declarative config. Prior to v2.2.0, the search tool allows LLMs to search for tools using natural language. While returning results, Hyperterse also returned the raw SQL queries, exposing statements which were supposed to be executed under the hood, and protected from being displayed publicly. This issue has been fixed as of v2.2.0.

CVSS 6.5 · Medium · EPSS 0.2% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • hyperterse

    Versions
    • >= 2.0.0, < 2.2.0: Affected

    No fix published

  • hyperterse npm

    Affected ranges
    • SEMVER: ≥ 2.0.0, < 2.2.0

    Update to 2.2.0

Original sources

Check your server →