p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de ruby-devise

Vulnerabilidades publicadas para ruby-devise en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 5

  1. CVE-2026-40295

    Media · CVSS 6.1EPSS 0,24%Sin corrección publicada

    Devise: Open Redirect via Unvalidated `request.referrer` in Timeoutable Session Timeout Handler

    Devise is an authentication solution for Rails based on Warden. In versions 5.0.3 and below, when the Timeoutable module is enabled in Devise, the FailureApp#redirect_url method returns request.referrer — the HTTP Referer header, which is attacker-controllable — without validation for any non-GET request that results in a session timeout. An attacker who hosts a page with an auto-submitting cross-origin form can cause a victim with an expired Devise session to be redirected to an arbitrary external URL. This contrasts with the GET timeout path (which uses server-side attempted_path) and Devise's own store_location_for mechanism (which strips

    Publicación Actualización
  2. CVE-2026-32700

    Media · CVSS 6EPSS 0,29%Sin corrección publicada

    Devise has a confirmable "change email" race condition that permits user to confirm email they have no access to

    Devise is an authentication solution for Rails based on Warden. Prior to version 5.0.3, a race condition in Devise's Confirmable module allows an attacker to confirm an email address they do not own. This affects any Devise application using the `reconfirmable` option (the default when using Confirmable with email changes). By sending two concurrent email change requests, an attacker can desynchronize the `confirmation_token` and `unconfirmed_email` fields. The confirmation token is sent to an email the attacker controls, but the `unconfirmed_email` in the database points to a victim's email address. When the attacker uses the token, the vict

    Publicación Actualización
  3. CVE-2019-5421

    Crítica · CVSS 9.8EPSS 1,56%Corrección disponible

    CVE-2019-5421

    Plataformatec Devise version 4.5.0 and earlier, using the lockable module contains a CWE-367 vulnerability in The `Devise::Models::Lockable` class, more specifically at the `#increment_failed_attempts` method. File location: lib/devise/models/lockable.rb that can result in Multiple concurrent requests can prevent an attacker from being blocked on brute force attacks. This attack appear to be exploitable via Network connectivity - brute force attacks. This vulnerability appears to have been fixed in 4.6.0 and later.

    • Actualiza a 4.5.0-3
    Publicación Actualización
  4. CVE-2013-0233

    Sin evaluarEPSS 14,13%Código de explotación públicoCorrección disponible

    CVE-2013-0233

    Devise gem 2.2.x before 2.2.3, 2.1.x before 2.1.3, 2.0.x before 2.0.5, and 1.5.x before 1.5.4 for Ruby, when using certain databases, does not properly perform type conversion when performing database queries, which might allow remote attackers to cause incorrect results to be returned and bypass security checks via unknown vectors, as demonstrated by resetting passwords of arbitrary accounts.

    • Actualiza a 3.4.1-1
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →