CVE-2026-40155
CVE-2026-40155 · Auth0 Next.js SDK has Improper Proxy Cache Lookup
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. In versions 4.12.0 through 4.17.1, simultaneous requests that trigger a nonce retry may cause the proxy cache fetcher to perform improper lookups for the token request results. Users are affected if their project uses both the vulnerable versions and the proxy handler /me/* and /my-org/* with DPoP enabled. This issue has been fixed in version 4.18.0.
CVSS 5.4 · Media · EPSS 0,2% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: node
Productos y versiones afectados
nextjs-auth0
- Versiones
- >= 4.12.0, < 4.18.0: Afectada
Sin corrección publicada
@auth0/nextjs-auth0 npm
- Intervalos de versiones afectados
- SEMVER: ≥ 4.12.0, < 4.18.0
Actualiza a 4.18.0