CVE-2026-40155
CVE-2026-40155 · Auth0 Next.js SDK has Improper Proxy Cache Lookup
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. In versions 4.12.0 through 4.17.1, simultaneous requests that trigger a nonce retry may cause the proxy cache fetcher to perform improper lookups for the token request results. Users are affected if their project uses both the vulnerable versions and the proxy handler /me/* and /my-org/* with DPoP enabled. This issue has been fixed in version 4.18.0.
CVSS 5.4 · Medium · EPSS 0.2% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
nextjs-auth0
- Versions
- >= 4.12.0, < 4.18.0: Affected
No fix published
@auth0/nextjs-auth0 npm
- Affected ranges
- SEMVER: ≥ 4.12.0, < 4.18.0
Update to 4.18.0