CVE-2026-40155
CVE-2026-40155 · Auth0 Next.js SDK has Improper Proxy Cache Lookup
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. In versions 4.12.0 through 4.17.1, simultaneous requests that trigger a nonce retry may cause the proxy cache fetcher to perform improper lookups for the token request results. Users are affected if their project uses both the vulnerable versions and the proxy handler /me/* and /my-org/* with DPoP enabled. This issue has been fixed in version 4.18.0.
CVSS 5.4 · Mittel · EPSS 0,2% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: node
Betroffene Produkte und Versionen
nextjs-auth0
- Softwareversionen
- >= 4.12.0, < 4.18.0: Betroffen
Keine Korrektur veröffentlicht
@auth0/nextjs-auth0 npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 4.12.0, < 4.18.0
Auf 4.18.0 aktualisieren