CVE-2026-41248
CVE-2026-41248 · Official Clerk JavaScript SDKs: Middleware-based route protection bypass
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Clerk JavaScript is the official JavaScript repository for Clerk authentication. createRouteMatcher in @clerk/nextjs, @clerk/nuxt, and @clerk/astro can be bypassed by certain crafted requests, allowing them to skip middleware gating and reach downstream handlers. This vulnerability is fixed in @clerk/astro 1.5.7, 2.17.10, and 3.0.15; @clerk/nextjs 5.7.6, 6.39.2, and 7.2.1; @clerk/nuxt 1.13.28 and 2.2.2; and @clerk/shared 2.22.1, 3.47.4, anc 4.8.1
CVSS 9.1 · Crítica · EPSS 0,3% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: node
Productos y versiones afectados
astro
- Versiones
- >= 0.0.1, < 1.5.7: Afectada
- >= 2.0.0-snapshot.v20241206174604, <= 2.17.9: Afectada
- >= 3.0.0, < 3.0.15: Afectada
Sin corrección publicada
nextjs
- Versiones
- >= 5.0.0, < 5.7.6: Afectada
- >= 6.0.0-snapshot.vb87a27f, < 6.39.2: Afectada
- >= 7.0.0, < 7.2.1: Afectada
Sin corrección publicada
nuxt
- Versiones
- >= 1.1.0, < 1.13.28: Afectada
- >= 2.0.0, < 2.2.2: Afectada
Sin corrección publicada
shared
- Versiones
- >= 2.20.17, < 2.22.1: Afectada
- >= 3.0.0-canary.v20250225091530, < 3.47.4: Afectada
- >= 4.0.0, < 4.8.1: Afectada
Sin corrección publicada
@clerk/nextjs npm
- Intervalos de versiones afectados
- SEMVER: ≥ 5.0.0, < 5.7.6
Actualiza a 5.7.6
@clerk/nuxt npm
- Intervalos de versiones afectados
- SEMVER: ≥ 1.1.0, < 1.13.28
Actualiza a 1.13.28
@clerk/astro npm
- Intervalos de versiones afectados
- SEMVER: ≥ 0.0.1, < 1.5.7
Actualiza a 1.5.7
@clerk/shared npm
- Intervalos de versiones afectados
- SEMVER: ≥ 2.20.17, < 2.22.1
Actualiza a 2.22.1
@clerk/nextjs npm
- Intervalos de versiones afectados
- SEMVER: ≥ 6.0.0-snapshot.vb87a27f, < 6.39.2
Actualiza a 6.39.2
@clerk/nextjs npm
- Intervalos de versiones afectados
- SEMVER: ≥ 7.0.0, < 7.2.1
Actualiza a 7.2.1
@clerk/nuxt npm
- Intervalos de versiones afectados
- SEMVER: ≥ 2.0.0, < 2.2.2
Actualiza a 2.2.2
@clerk/astro npm
- Intervalos de versiones afectados
- SEMVER: ≥ 2.0.0-snapshot.v20241206174604, < 2.17.10
Actualiza a 2.17.10
@clerk/astro npm
- Intervalos de versiones afectados
- SEMVER: ≥ 3.0.0, < 3.0.15
Actualiza a 3.0.15
@clerk/shared npm
- Intervalos de versiones afectados
- SEMVER: ≥ 3.0.0-canary.v20250225091530, < 3.47.4
Actualiza a 3.47.4
@clerk/shared npm
- Intervalos de versiones afectados
- SEMVER: ≥ 4.0.0, < 4.8.1
Actualiza a 4.8.1