CVE-2026-41248
CVE-2026-41248 · Official Clerk JavaScript SDKs: Middleware-based route protection bypass
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Clerk JavaScript is the official JavaScript repository for Clerk authentication. createRouteMatcher in @clerk/nextjs, @clerk/nuxt, and @clerk/astro can be bypassed by certain crafted requests, allowing them to skip middleware gating and reach downstream handlers. This vulnerability is fixed in @clerk/astro 1.5.7, 2.17.10, and 3.0.15; @clerk/nextjs 5.7.6, 6.39.2, and 7.2.1; @clerk/nuxt 1.13.28 and 2.2.2; and @clerk/shared 2.22.1, 3.47.4, anc 4.8.1
CVSS 9.1 · Critical · EPSS 0.3% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
astro
- Versions
- >= 0.0.1, < 1.5.7: Affected
- >= 2.0.0-snapshot.v20241206174604, <= 2.17.9: Affected
- >= 3.0.0, < 3.0.15: Affected
No fix published
nextjs
- Versions
- >= 5.0.0, < 5.7.6: Affected
- >= 6.0.0-snapshot.vb87a27f, < 6.39.2: Affected
- >= 7.0.0, < 7.2.1: Affected
No fix published
nuxt
- Versions
- >= 1.1.0, < 1.13.28: Affected
- >= 2.0.0, < 2.2.2: Affected
No fix published
shared
- Versions
- >= 2.20.17, < 2.22.1: Affected
- >= 3.0.0-canary.v20250225091530, < 3.47.4: Affected
- >= 4.0.0, < 4.8.1: Affected
No fix published
@clerk/nextjs npm
- Affected ranges
- SEMVER: ≥ 5.0.0, < 5.7.6
Update to 5.7.6
@clerk/nuxt npm
- Affected ranges
- SEMVER: ≥ 1.1.0, < 1.13.28
Update to 1.13.28
@clerk/astro npm
- Affected ranges
- SEMVER: ≥ 0.0.1, < 1.5.7
Update to 1.5.7
@clerk/shared npm
- Affected ranges
- SEMVER: ≥ 2.20.17, < 2.22.1
Update to 2.22.1
@clerk/nextjs npm
- Affected ranges
- SEMVER: ≥ 6.0.0-snapshot.vb87a27f, < 6.39.2
Update to 6.39.2
@clerk/nextjs npm
- Affected ranges
- SEMVER: ≥ 7.0.0, < 7.2.1
Update to 7.2.1
@clerk/nuxt npm
- Affected ranges
- SEMVER: ≥ 2.0.0, < 2.2.2
Update to 2.2.2
@clerk/astro npm
- Affected ranges
- SEMVER: ≥ 2.0.0-snapshot.v20241206174604, < 2.17.10
Update to 2.17.10
@clerk/astro npm
- Affected ranges
- SEMVER: ≥ 3.0.0, < 3.0.15
Update to 3.0.15
@clerk/shared npm
- Affected ranges
- SEMVER: ≥ 3.0.0-canary.v20250225091530, < 3.47.4
Update to 3.47.4
@clerk/shared npm
- Affected ranges
- SEMVER: ≥ 4.0.0, < 4.8.1
Update to 4.8.1