p PatchFirst

CVE-2026-41248

CVE-2026-41248 · Official Clerk JavaScript SDKs: Middleware-based route protection bypass

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Clerk JavaScript is the official JavaScript repository for Clerk authentication. createRouteMatcher in @clerk/nextjs, @clerk/nuxt, and @clerk/astro can be bypassed by certain crafted requests, allowing them to skip middleware gating and reach downstream handlers. This vulnerability is fixed in @clerk/astro 1.5.7, 2.17.10, and 3.0.15; @clerk/nextjs 5.7.6, 6.39.2, and 7.2.1; @clerk/nuxt 1.13.28 and 2.2.2; and @clerk/shared 2.22.1, 3.47.4, anc 4.8.1

CVSS 9.1 · Kritisch · EPSS 0,3% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • astro

    Softwareversionen
    • >= 0.0.1, < 1.5.7: Betroffen
    • >= 2.0.0-snapshot.v20241206174604, <= 2.17.9: Betroffen
    • >= 3.0.0, < 3.0.15: Betroffen

    Keine Korrektur veröffentlicht

  • nextjs

    Softwareversionen
    • >= 5.0.0, < 5.7.6: Betroffen
    • >= 6.0.0-snapshot.vb87a27f, < 6.39.2: Betroffen
    • >= 7.0.0, < 7.2.1: Betroffen

    Keine Korrektur veröffentlicht

  • nuxt

    Softwareversionen
    • >= 1.1.0, < 1.13.28: Betroffen
    • >= 2.0.0, < 2.2.2: Betroffen

    Keine Korrektur veröffentlicht

  • shared

    Softwareversionen
    • >= 2.20.17, < 2.22.1: Betroffen
    • >= 3.0.0-canary.v20250225091530, < 3.47.4: Betroffen
    • >= 4.0.0, < 4.8.1: Betroffen

    Keine Korrektur veröffentlicht

  • @clerk/nextjs npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 5.0.0, < 5.7.6

    Auf 5.7.6 aktualisieren

  • @clerk/nuxt npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 1.1.0, < 1.13.28

    Auf 1.13.28 aktualisieren

  • @clerk/astro npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 0.0.1, < 1.5.7

    Auf 1.5.7 aktualisieren

  • @clerk/shared npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 2.20.17, < 2.22.1

    Auf 2.22.1 aktualisieren

  • @clerk/nextjs npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 6.0.0-snapshot.vb87a27f, < 6.39.2

    Auf 6.39.2 aktualisieren

  • @clerk/nextjs npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 7.0.0, < 7.2.1

    Auf 7.2.1 aktualisieren

  • @clerk/nuxt npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 2.0.0, < 2.2.2

    Auf 2.2.2 aktualisieren

  • @clerk/astro npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 2.0.0-snapshot.v20241206174604, < 2.17.10

    Auf 2.17.10 aktualisieren

  • @clerk/astro npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 3.0.0, < 3.0.15

    Auf 3.0.15 aktualisieren

  • @clerk/shared npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 3.0.0-canary.v20250225091530, < 3.47.4

    Auf 3.47.4 aktualisieren

  • @clerk/shared npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 4.0.0, < 4.8.1

    Auf 4.8.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →