CVE-2026-41989
CVE-2026-41989
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Libgcrypt before 1.12.2 sometimes allows a heap-based buffer overflow and denial of service via crafted ECDH ciphertext to gcry_pk_decrypt.
CVSS 6.7 · Media · EPSS 0,2% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
libgcrypt
- Versiones
- ≥ 1.8.8, < 1.10.4: Afectada (semver)
- ≥ 1.11.0, < 1.11.3: Afectada (semver)
- ≥ 1.12.0, < 1.12.2: Afectada (semver)
Actualiza a 1.10.4; Actualiza a 1.11.3; Actualiza a 1.12.2
libgcrypt20 Debian:12
- Versiones
- 1.10.1-3
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.10.1-3+deb12u1
Actualiza a 1.10.1-3+deb12u1
libgcrypt20 Debian:13
- Versiones
- 1.11.0-7
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.11.0-7+deb13u1
Actualiza a 1.11.0-7+deb13u1
libgcrypt20 Debian:14
- Versiones
- 1.11.0+git20250114-1
- 1.11.0-7
- 1.11.1-1
- 1.11.2-1
- 1.11.2-2
- 1.11.2-3
- 1.12.0-1
- 1.12.0-2
- 1.12.1-1
- 1.12.1-2
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.12.2-1
Actualiza a 1.12.2-1
libgcrypt20 Ubuntu:Pro:16.04:LTS
- Versiones
- 1.6.3-2ubuntu1
- 1.6.4-3
- 1.6.4-4
- 1.6.4-5
- 1.6.5-2
- 1.6.5-2ubuntu0.2
- 1.6.5-2ubuntu0.3
- 1.6.5-2ubuntu0.4
- 1.6.5-2ubuntu0.5
- 1.6.5-2ubuntu0.6
- 1.6.5-2ubuntu0.6+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
libgcrypt20 Ubuntu:18.04:LTS
- Versiones
- 1.7.8-2ubuntu1
- 1.7.9-1
- 1.8.1-4
- 1.8.1-4ubuntu1
- 1.8.1-4ubuntu1.1
- 1.8.1-4ubuntu1.2
- 1.8.1-4ubuntu1.3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
libgcrypt20 Ubuntu:Pro:FIPS-updates:18.04:LTS
- Versiones
- 1.8.1-4ubuntu1.fips.2.4
- 1.8.1-4ubuntu1.fips.2.5
- 1.8.1-4ubuntu1.fips.3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
libgcrypt20 Ubuntu:Pro:FIPS:18.04:LTS
- Versiones
- 1.8.1-4ubuntu1.fips.2.4
- 1.8.1-4ubuntu1.fips.2.5
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
libgcrypt20 Ubuntu:20.04:LTS
- Versiones
- 1.8.4-5ubuntu2
- 1.8.5-3ubuntu1
- 1.8.5-5ubuntu1
- 1.8.5-5ubuntu1.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
libgcrypt20 Ubuntu:Pro:FIPS-updates:20.04:LTS
- Versiones
- 1.8.5-5ubuntu1.fips.1.1
- 1.8.5-5ubuntu1.fips.1.4
- 1.8.5-5ubuntu1.fips.1.5
- 1.8.5-5ubuntu1.fips.1.7
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
libgcrypt20 Ubuntu:Pro:FIPS:20.04:LTS
- Versiones
- 1.8.5-5ubuntu1.fips.1.1
- 1.8.5-5ubuntu1.fips.1.4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
libgcrypt20 Ubuntu:22.04:LTS
- Versiones
- 1.8.7-5ubuntu2
- 1.9.4-3ubuntu2
- 1.9.4-3ubuntu3
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.9.4-3ubuntu3.2
Actualiza a 1.9.4-3ubuntu3.2
libgcrypt20 Ubuntu:Pro:FIPS-preview:22.04:LTS
- Versiones
- 1.9.4-3ubuntu3+Fips1.1
- 1.9.4-3ubuntu3+Fips1.2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
libgcrypt20 Ubuntu:Pro:FIPS-updates:22.04:LTS
- Versiones
- 1.9.4-3ubuntu3+Fips1.1
- 1.9.4-3ubuntu3+Fips1.2
- 1.9.4-3ubuntu3+Fips1.3
- 1.9.4-3ubuntu3+Fips1.4
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.9.4-3ubuntu3.2+Fips1
Actualiza a 1.9.4-3ubuntu3.2+Fips1
libgcrypt20 Ubuntu:24.04:LTS
- Versiones
- 1.10.2-3ubuntu1
- 1.10.3-2
- 1.10.3-2build1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.10.3-2ubuntu0.1
Actualiza a 1.10.3-2ubuntu0.1
libgcrypt20 Ubuntu:Pro:FIPS-updates:24.04:LTS
- Versiones
- 1.10.3-2ubuntu0.1~Fips1~rc6
- 1.10.3-2ubuntu0.1~Fips1~rc7
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.12.0-2ubuntu0.1~Fips1~rc11
Actualiza a 1.12.0-2ubuntu0.1~Fips1~rc11
libgcrypt20 Ubuntu:25.10
- Versiones
- 1.11.0-6ubuntu1
- 1.11.0-7
- 1.11.0-7build1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.11.0-7ubuntu0.1
Actualiza a 1.11.0-7ubuntu0.1
libgcrypt20 Ubuntu:26.04:LTS
- Versiones
- 1.11.0-7build1
- 1.11.2-2
- 1.11.2-3
- 1.12.0-2
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.12.0-2ubuntu0.1
Actualiza a 1.12.0-2ubuntu0.1
Fuentes originales
- https://lists.gnupg.org/pipermail/gnupg-announce/2026q2/000503.html
- https://dev.gnupg.org/T8211
- https://www.openwall.com/lists/oss-security/2026/04/21/1
- https://cert-portal.siemens.com/productcert/html/ssa-082556.html
- https://cert-portal.siemens.com/productcert/html/ssa-019113.html
- https://cert-portal.siemens.com/productcert/html/ssa-457936.html
- https://nvd.nist.gov/vuln/detail/CVE-2026-41989