p PatchFirst

CVE-2026-41989

CVE-2026-41989

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Libgcrypt before 1.12.2 sometimes allows a heap-based buffer overflow and denial of service via crafted ECDH ciphertext to gcry_pk_decrypt.

CVSS 6.7 · Moyenne · EPSS 0,2% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system

Produits et versions concernés

  • libgcrypt

    Versions du logiciel
    • ≥ 1.8.8, < 1.10.4: Concernée (semver)
    • ≥ 1.11.0, < 1.11.3: Concernée (semver)
    • ≥ 1.12.0, < 1.12.2: Concernée (semver)

    Mettez à jour vers 1.10.4; Mettez à jour vers 1.11.3; Mettez à jour vers 1.12.2

  • libgcrypt20 Debian:12

    Versions du logiciel
    • 1.10.1-3
    Plages de versions concernées
    • ECOSYSTEM: < 1.10.1-3+deb12u1

    Mettez à jour vers 1.10.1-3+deb12u1

  • libgcrypt20 Debian:13

    Versions du logiciel
    • 1.11.0-7
    Plages de versions concernées
    • ECOSYSTEM: < 1.11.0-7+deb13u1

    Mettez à jour vers 1.11.0-7+deb13u1

  • libgcrypt20 Debian:14

    Versions du logiciel
    • 1.11.0+git20250114-1
    • 1.11.0-7
    • 1.11.1-1
    • 1.11.2-1
    • 1.11.2-2
    • 1.11.2-3
    • 1.12.0-1
    • 1.12.0-2
    • 1.12.1-1
    • 1.12.1-2
    Plages de versions concernées
    • ECOSYSTEM: < 1.12.2-1

    Mettez à jour vers 1.12.2-1

  • libgcrypt20 Ubuntu:Pro:16.04:LTS

    Versions du logiciel
    • 1.6.3-2ubuntu1
    • 1.6.4-3
    • 1.6.4-4
    • 1.6.4-5
    • 1.6.5-2
    • 1.6.5-2ubuntu0.2
    • 1.6.5-2ubuntu0.3
    • 1.6.5-2ubuntu0.4
    • 1.6.5-2ubuntu0.5
    • 1.6.5-2ubuntu0.6
    • 1.6.5-2ubuntu0.6+esm1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • libgcrypt20 Ubuntu:18.04:LTS

    Versions du logiciel
    • 1.7.8-2ubuntu1
    • 1.7.9-1
    • 1.8.1-4
    • 1.8.1-4ubuntu1
    • 1.8.1-4ubuntu1.1
    • 1.8.1-4ubuntu1.2
    • 1.8.1-4ubuntu1.3
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • libgcrypt20 Ubuntu:Pro:FIPS-updates:18.04:LTS

    Versions du logiciel
    • 1.8.1-4ubuntu1.fips.2.4
    • 1.8.1-4ubuntu1.fips.2.5
    • 1.8.1-4ubuntu1.fips.3
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • libgcrypt20 Ubuntu:Pro:FIPS:18.04:LTS

    Versions du logiciel
    • 1.8.1-4ubuntu1.fips.2.4
    • 1.8.1-4ubuntu1.fips.2.5
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • libgcrypt20 Ubuntu:20.04:LTS

    Versions du logiciel
    • 1.8.4-5ubuntu2
    • 1.8.5-3ubuntu1
    • 1.8.5-5ubuntu1
    • 1.8.5-5ubuntu1.1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • libgcrypt20 Ubuntu:Pro:FIPS-updates:20.04:LTS

    Versions du logiciel
    • 1.8.5-5ubuntu1.fips.1.1
    • 1.8.5-5ubuntu1.fips.1.4
    • 1.8.5-5ubuntu1.fips.1.5
    • 1.8.5-5ubuntu1.fips.1.7
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • libgcrypt20 Ubuntu:Pro:FIPS:20.04:LTS

    Versions du logiciel
    • 1.8.5-5ubuntu1.fips.1.1
    • 1.8.5-5ubuntu1.fips.1.4
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • libgcrypt20 Ubuntu:22.04:LTS

    Versions du logiciel
    • 1.8.7-5ubuntu2
    • 1.9.4-3ubuntu2
    • 1.9.4-3ubuntu3
    Plages de versions concernées
    • ECOSYSTEM: < 1.9.4-3ubuntu3.2

    Mettez à jour vers 1.9.4-3ubuntu3.2

  • libgcrypt20 Ubuntu:Pro:FIPS-preview:22.04:LTS

    Versions du logiciel
    • 1.9.4-3ubuntu3+Fips1.1
    • 1.9.4-3ubuntu3+Fips1.2
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • libgcrypt20 Ubuntu:Pro:FIPS-updates:22.04:LTS

    Versions du logiciel
    • 1.9.4-3ubuntu3+Fips1.1
    • 1.9.4-3ubuntu3+Fips1.2
    • 1.9.4-3ubuntu3+Fips1.3
    • 1.9.4-3ubuntu3+Fips1.4
    Plages de versions concernées
    • ECOSYSTEM: < 1.9.4-3ubuntu3.2+Fips1

    Mettez à jour vers 1.9.4-3ubuntu3.2+Fips1

  • libgcrypt20 Ubuntu:24.04:LTS

    Versions du logiciel
    • 1.10.2-3ubuntu1
    • 1.10.3-2
    • 1.10.3-2build1
    Plages de versions concernées
    • ECOSYSTEM: < 1.10.3-2ubuntu0.1

    Mettez à jour vers 1.10.3-2ubuntu0.1

  • libgcrypt20 Ubuntu:Pro:FIPS-updates:24.04:LTS

    Versions du logiciel
    • 1.10.3-2ubuntu0.1~Fips1~rc6
    • 1.10.3-2ubuntu0.1~Fips1~rc7
    Plages de versions concernées
    • ECOSYSTEM: < 1.12.0-2ubuntu0.1~Fips1~rc11

    Mettez à jour vers 1.12.0-2ubuntu0.1~Fips1~rc11

  • libgcrypt20 Ubuntu:25.10

    Versions du logiciel
    • 1.11.0-6ubuntu1
    • 1.11.0-7
    • 1.11.0-7build1
    Plages de versions concernées
    • ECOSYSTEM: < 1.11.0-7ubuntu0.1

    Mettez à jour vers 1.11.0-7ubuntu0.1

  • libgcrypt20 Ubuntu:26.04:LTS

    Versions du logiciel
    • 1.11.0-7build1
    • 1.11.2-2
    • 1.11.2-3
    • 1.12.0-2
    Plages de versions concernées
    • ECOSYSTEM: < 1.12.0-2ubuntu0.1

    Mettez à jour vers 1.12.0-2ubuntu0.1

Sources originales

Vérifiez votre serveur →