CVE-2026-41989
CVE-2026-41989
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Libgcrypt before 1.12.2 sometimes allows a heap-based buffer overflow and denial of service via crafted ECDH ciphertext to gcry_pk_decrypt.
CVSS 6.7 · Mittel · EPSS 0,2% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
libgcrypt
- Softwareversionen
- ≥ 1.8.8, < 1.10.4: Betroffen (semver)
- ≥ 1.11.0, < 1.11.3: Betroffen (semver)
- ≥ 1.12.0, < 1.12.2: Betroffen (semver)
Auf 1.10.4 aktualisieren; Auf 1.11.3 aktualisieren; Auf 1.12.2 aktualisieren
libgcrypt20 Debian:12
- Softwareversionen
- 1.10.1-3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.10.1-3+deb12u1
Auf 1.10.1-3+deb12u1 aktualisieren
libgcrypt20 Debian:13
- Softwareversionen
- 1.11.0-7
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.11.0-7+deb13u1
Auf 1.11.0-7+deb13u1 aktualisieren
libgcrypt20 Debian:14
- Softwareversionen
- 1.11.0+git20250114-1
- 1.11.0-7
- 1.11.1-1
- 1.11.2-1
- 1.11.2-2
- 1.11.2-3
- 1.12.0-1
- 1.12.0-2
- 1.12.1-1
- 1.12.1-2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.12.2-1
Auf 1.12.2-1 aktualisieren
libgcrypt20 Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 1.6.3-2ubuntu1
- 1.6.4-3
- 1.6.4-4
- 1.6.4-5
- 1.6.5-2
- 1.6.5-2ubuntu0.2
- 1.6.5-2ubuntu0.3
- 1.6.5-2ubuntu0.4
- 1.6.5-2ubuntu0.5
- 1.6.5-2ubuntu0.6
- 1.6.5-2ubuntu0.6+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
libgcrypt20 Ubuntu:18.04:LTS
- Softwareversionen
- 1.7.8-2ubuntu1
- 1.7.9-1
- 1.8.1-4
- 1.8.1-4ubuntu1
- 1.8.1-4ubuntu1.1
- 1.8.1-4ubuntu1.2
- 1.8.1-4ubuntu1.3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
libgcrypt20 Ubuntu:Pro:FIPS-updates:18.04:LTS
- Softwareversionen
- 1.8.1-4ubuntu1.fips.2.4
- 1.8.1-4ubuntu1.fips.2.5
- 1.8.1-4ubuntu1.fips.3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
libgcrypt20 Ubuntu:Pro:FIPS:18.04:LTS
- Softwareversionen
- 1.8.1-4ubuntu1.fips.2.4
- 1.8.1-4ubuntu1.fips.2.5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
libgcrypt20 Ubuntu:20.04:LTS
- Softwareversionen
- 1.8.4-5ubuntu2
- 1.8.5-3ubuntu1
- 1.8.5-5ubuntu1
- 1.8.5-5ubuntu1.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
libgcrypt20 Ubuntu:Pro:FIPS-updates:20.04:LTS
- Softwareversionen
- 1.8.5-5ubuntu1.fips.1.1
- 1.8.5-5ubuntu1.fips.1.4
- 1.8.5-5ubuntu1.fips.1.5
- 1.8.5-5ubuntu1.fips.1.7
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
libgcrypt20 Ubuntu:Pro:FIPS:20.04:LTS
- Softwareversionen
- 1.8.5-5ubuntu1.fips.1.1
- 1.8.5-5ubuntu1.fips.1.4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
libgcrypt20 Ubuntu:22.04:LTS
- Softwareversionen
- 1.8.7-5ubuntu2
- 1.9.4-3ubuntu2
- 1.9.4-3ubuntu3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.9.4-3ubuntu3.2
Auf 1.9.4-3ubuntu3.2 aktualisieren
libgcrypt20 Ubuntu:Pro:FIPS-preview:22.04:LTS
- Softwareversionen
- 1.9.4-3ubuntu3+Fips1.1
- 1.9.4-3ubuntu3+Fips1.2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
libgcrypt20 Ubuntu:Pro:FIPS-updates:22.04:LTS
- Softwareversionen
- 1.9.4-3ubuntu3+Fips1.1
- 1.9.4-3ubuntu3+Fips1.2
- 1.9.4-3ubuntu3+Fips1.3
- 1.9.4-3ubuntu3+Fips1.4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.9.4-3ubuntu3.2+Fips1
Auf 1.9.4-3ubuntu3.2+Fips1 aktualisieren
libgcrypt20 Ubuntu:24.04:LTS
- Softwareversionen
- 1.10.2-3ubuntu1
- 1.10.3-2
- 1.10.3-2build1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.10.3-2ubuntu0.1
Auf 1.10.3-2ubuntu0.1 aktualisieren
libgcrypt20 Ubuntu:Pro:FIPS-updates:24.04:LTS
- Softwareversionen
- 1.10.3-2ubuntu0.1~Fips1~rc6
- 1.10.3-2ubuntu0.1~Fips1~rc7
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.12.0-2ubuntu0.1~Fips1~rc11
Auf 1.12.0-2ubuntu0.1~Fips1~rc11 aktualisieren
libgcrypt20 Ubuntu:25.10
- Softwareversionen
- 1.11.0-6ubuntu1
- 1.11.0-7
- 1.11.0-7build1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.11.0-7ubuntu0.1
Auf 1.11.0-7ubuntu0.1 aktualisieren
libgcrypt20 Ubuntu:26.04:LTS
- Softwareversionen
- 1.11.0-7build1
- 1.11.2-2
- 1.11.2-3
- 1.12.0-2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.12.0-2ubuntu0.1
Auf 1.12.0-2ubuntu0.1 aktualisieren
Originalquellen
- https://lists.gnupg.org/pipermail/gnupg-announce/2026q2/000503.html
- https://dev.gnupg.org/T8211
- https://www.openwall.com/lists/oss-security/2026/04/21/1
- https://cert-portal.siemens.com/productcert/html/ssa-082556.html
- https://cert-portal.siemens.com/productcert/html/ssa-019113.html
- https://cert-portal.siemens.com/productcert/html/ssa-457936.html
- https://nvd.nist.gov/vuln/detail/CVE-2026-41989