p PatchFirst

CVE-2026-42089

CVE-2026-42089 · yeoman-environment Vulnerable to Arbitrary Package Installation without User Confirmation

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Yeoman Environment provides an API to discover, create, and run generators, and to configure where and how a generator is resolved. Versions 2.9.0 through 6.0.0 install missing local generator packages from caller-supplied package names without user confirmation. In downstream consumers that pass attacker-controlled project configuration into this path, this can result in arbitrary package installation and code execution during CLI bootstrap. The vulnerable method is installLocalGenerators(), which calls repository.install() directly without prompting the user. This issue has been fixed in version 6.0.0.

CVSS 8.6 · Alta · EPSS 0,2% · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • environment

    Versiones
    • >= 2.9.0, < 6.0.1: Afectada

    Sin corrección publicada

  • yeoman-environment npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 2.9.0, < 6.0.1

    Actualiza a 6.0.1

Fuentes originales

Comprueba tu servidor →