p PatchFirst

CVE-2026-42089

CVE-2026-42089 · yeoman-environment Vulnerable to Arbitrary Package Installation without User Confirmation

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Yeoman Environment provides an API to discover, create, and run generators, and to configure where and how a generator is resolved. Versions 2.9.0 through 6.0.0 install missing local generator packages from caller-supplied package names without user confirmation. In downstream consumers that pass attacker-controlled project configuration into this path, this can result in arbitrary package installation and code execution during CLI bootstrap. The vulnerable method is installLocalGenerators(), which calls repository.install() directly without prompting the user. This issue has been fixed in version 6.0.0.

CVSS 8.6 · Élevée · EPSS 0,2% · Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • environment

    Versions du logiciel
    • >= 2.9.0, < 6.0.1: Concernée

    Aucun correctif publié

  • yeoman-environment npm

    Plages de versions concernées
    • SEMVER: ≥ 2.9.0, < 6.0.1

    Mettez à jour vers 6.0.1

Sources originales

Vérifiez votre serveur →