p PatchFirst

CVE-2026-42089

CVE-2026-42089 · yeoman-environment Vulnerable to Arbitrary Package Installation without User Confirmation

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Yeoman Environment provides an API to discover, create, and run generators, and to configure where and how a generator is resolved. Versions 2.9.0 through 6.0.0 install missing local generator packages from caller-supplied package names without user confirmation. In downstream consumers that pass attacker-controlled project configuration into this path, this can result in arbitrary package installation and code execution during CLI bootstrap. The vulnerable method is installLocalGenerators(), which calls repository.install() directly without prompting the user. This issue has been fixed in version 6.0.0.

CVSS 8.6 · Hoch · EPSS 0,2% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • environment

    Softwareversionen
    • >= 2.9.0, < 6.0.1: Betroffen

    Keine Korrektur veröffentlicht

  • yeoman-environment npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 2.9.0, < 6.0.1

    Auf 6.0.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →