p PatchFirst

CVE-2026-44724

CVE-2026-44724 · systeminformation: Linux command injection in networkInterfaces() via unsanitized NetworkManager connection profile name

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

systeminformation is a System and OS information library for node.js. From 4.17.0 to 5.31.5, on Linux, systeminformation is vulnerable to command injection in networkInterfaces() when an active NetworkManager connection profile name contains shell metacharacters. The vulnerable value is obtained internally from real nmcli device status output. The library sanitizes the network interface name before using it in shell commands, but it does not apply equivalent sanitization to the parsed NetworkManager connection profile name. That unsanitized connectionName is then interpolated into three shell command strings executed through execSync(). This vulnerability is fixed in 5.31.6.

CVSS 7.8 · Alta · EPSS 0,8% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · node

Productos y versiones afectados

  • systeminformation

    Versiones
    • >= 4.17.0, < 5.31.6: Afectada

    Sin corrección publicada

  • jupyterlab Debian:13

    Versiones
    • 4.0.11+ds1+~cs11.25.27-7
    • 4.0.11+ds1+~cs11.25.27-8
    • 4.0.11+ds1+~cs11.25.27-9
    • 4.0.11+ds2+~cs11.25.27-1
    • 4.0.11+ds2+~cs11.25.27-3
    • 4.0.11+ds3+~cs11.25.27-1
    • 4.0.11+ds4+~cs11.25.27-1
    • 4.0.11+ds4+~cs11.25.27-2
    • 4.0.11+ds4+~cs11.25.27-3
    • 4.0.11+ds4+~cs11.25.27-4
    • 4.0.11+ds5+~cs11.25.27-1
    • 4.0.13+ds1+~2.0.1+~cs1.4.4-1
    • 4.1.3+ds1+~2.0.1+~0.15.3+~cs1.4.4-1
    • 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-1
    • 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-2
    • 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-3
    • 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-4
    • 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-5
    • 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-6
    • 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-7
    • 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-8
    • 4.4.1+ds1+~3.0.5+~0.16.6+~cs1.4.4-1
    • 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-1
    • 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-2
    • 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-3
    • 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4
    • 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-5
    • 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-6
    • 4.4.8+ds1+~3.1.0+~0.16.6+~cs1.4.4-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • jupyterlab Debian:14

    Versiones
    • 4.0.11+ds1+~cs11.25.27-7
    • 4.0.11+ds1+~cs11.25.27-8
    • 4.0.11+ds1+~cs11.25.27-9
    • 4.0.11+ds2+~cs11.25.27-1
    • 4.0.11+ds2+~cs11.25.27-3
    • 4.0.11+ds3+~cs11.25.27-1
    • 4.0.11+ds4+~cs11.25.27-1
    • 4.0.11+ds4+~cs11.25.27-2
    • 4.0.11+ds4+~cs11.25.27-3
    • 4.0.11+ds4+~cs11.25.27-4
    Intervalos de versiones afectados
    • ECOSYSTEM: < 4.0.11+ds5+~cs11.25.27-1

    Actualiza a 4.0.11+ds5+~cs11.25.27-1

  • systeminformation npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 4.17.0, < 5.31.6

    Actualiza a 5.31.6

  • jupyterlab Ubuntu:25.10

    Versiones
    • 4.0.11+ds1+~cs11.25.27-5
    • 4.0.11+ds1+~cs11.25.27-6
    • 4.0.11+ds1+~cs11.25.27-7
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • jupyterlab Ubuntu:26.10

    Versiones
    • 4.0.11+ds1+~cs11.25.27-9
    • 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-3
    • 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-systeminformation Ubuntu:26.10

    Versiones
    • 5.31.6-4
    • 5.31.7-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • jupyterlab Ubuntu:26.04:LTS

    Versiones
    • 4.0.11+ds1+~cs11.25.27-7
    • 4.0.11+ds1+~cs11.25.27-8
    • 4.0.11+ds1+~cs11.25.27-9
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →