CVE-2026-44724
CVE-2026-44724 · systeminformation: Linux command injection in networkInterfaces() via unsanitized NetworkManager connection profile name
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
systeminformation is a System and OS information library for node.js. From 4.17.0 to 5.31.5, on Linux, systeminformation is vulnerable to command injection in networkInterfaces() when an active NetworkManager connection profile name contains shell metacharacters. The vulnerable value is obtained internally from real nmcli device status output. The library sanitizes the network interface name before using it in shell commands, but it does not apply equivalent sanitization to the parsed NetworkManager connection profile name. That unsanitized connectionName is then interpolated into three shell command strings executed through execSync(). This vulnerability is fixed in 5.31.6.
CVSS 7.8 · Élevée · EPSS 0,9% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · node
Produits et versions concernés
systeminformation
- Versions du logiciel
- >= 4.17.0, < 5.31.6: Concernée
Aucun correctif publié
jupyterlab Debian:13
- Versions du logiciel
- 4.0.11+ds1+~cs11.25.27-7
- 4.0.11+ds1+~cs11.25.27-8
- 4.0.11+ds1+~cs11.25.27-9
- 4.0.11+ds2+~cs11.25.27-1
- 4.0.11+ds2+~cs11.25.27-3
- 4.0.11+ds3+~cs11.25.27-1
- 4.0.11+ds4+~cs11.25.27-1
- 4.0.11+ds4+~cs11.25.27-2
- 4.0.11+ds4+~cs11.25.27-3
- 4.0.11+ds4+~cs11.25.27-4
- 4.0.11+ds5+~cs11.25.27-1
- 4.0.13+ds1+~2.0.1+~cs1.4.4-1
- 4.1.3+ds1+~2.0.1+~0.15.3+~cs1.4.4-1
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-1
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-2
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-3
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-4
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-5
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-6
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-7
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-8
- 4.4.1+ds1+~3.0.5+~0.16.6+~cs1.4.4-1
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-1
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-2
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-3
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-5
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-6
- 4.4.8+ds1+~3.1.0+~0.16.6+~cs1.4.4-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
jupyterlab Debian:14
- Versions du logiciel
- 4.0.11+ds1+~cs11.25.27-7
- 4.0.11+ds1+~cs11.25.27-8
- 4.0.11+ds1+~cs11.25.27-9
- 4.0.11+ds2+~cs11.25.27-1
- 4.0.11+ds2+~cs11.25.27-3
- 4.0.11+ds3+~cs11.25.27-1
- 4.0.11+ds4+~cs11.25.27-1
- 4.0.11+ds4+~cs11.25.27-2
- 4.0.11+ds4+~cs11.25.27-3
- 4.0.11+ds4+~cs11.25.27-4
- Plages de versions concernées
- ECOSYSTEM: < 4.0.11+ds5+~cs11.25.27-1
Mettez à jour vers 4.0.11+ds5+~cs11.25.27-1
systeminformation npm
- Plages de versions concernées
- SEMVER: ≥ 4.17.0, < 5.31.6
Mettez à jour vers 5.31.6
jupyterlab Ubuntu:25.10
- Versions du logiciel
- 4.0.11+ds1+~cs11.25.27-5
- 4.0.11+ds1+~cs11.25.27-6
- 4.0.11+ds1+~cs11.25.27-7
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
jupyterlab Ubuntu:26.10
- Versions du logiciel
- 4.0.11+ds1+~cs11.25.27-9
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-3
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-systeminformation Ubuntu:26.10
- Versions du logiciel
- 5.31.6-4
- 5.31.7-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
jupyterlab Ubuntu:26.04:LTS
- Versions du logiciel
- 4.0.11+ds1+~cs11.25.27-7
- 4.0.11+ds1+~cs11.25.27-8
- 4.0.11+ds1+~cs11.25.27-9
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
Sources originales
- https://github.com/sebhildebrandt/systeminformation/security/advisories/GHSA-hvx9-hwr7-wjj9
- https://access.redhat.com/security/cve/CVE-2026-44724
- https://bugzilla.redhat.com/show_bug.cgi?id=2482416
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-44724.json
- https://access.redhat.com/errata/RHSA-2026:33574
- https://access.redhat.com/errata/RHSA-2026:60520
- https://nvd.nist.gov/vuln/detail/CVE-2026-44724