p PatchFirst

CVE-2026-44724

CVE-2026-44724 · systeminformation: Linux command injection in networkInterfaces() via unsanitized NetworkManager connection profile name

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

systeminformation is a System and OS information library for node.js. From 4.17.0 to 5.31.5, on Linux, systeminformation is vulnerable to command injection in networkInterfaces() when an active NetworkManager connection profile name contains shell metacharacters. The vulnerable value is obtained internally from real nmcli device status output. The library sanitizes the network interface name before using it in shell commands, but it does not apply equivalent sanitization to the parsed NetworkManager connection profile name. That unsanitized connectionName is then interpolated into three shell command strings executed through execSync(). This vulnerability is fixed in 5.31.6.

CVSS 7.8 · Hoch · EPSS 0,8% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • systeminformation

    Softwareversionen
    • >= 4.17.0, < 5.31.6: Betroffen

    Keine Korrektur veröffentlicht

  • jupyterlab Debian:13

    Softwareversionen
    • 4.0.11+ds1+~cs11.25.27-7
    • 4.0.11+ds1+~cs11.25.27-8
    • 4.0.11+ds1+~cs11.25.27-9
    • 4.0.11+ds2+~cs11.25.27-1
    • 4.0.11+ds2+~cs11.25.27-3
    • 4.0.11+ds3+~cs11.25.27-1
    • 4.0.11+ds4+~cs11.25.27-1
    • 4.0.11+ds4+~cs11.25.27-2
    • 4.0.11+ds4+~cs11.25.27-3
    • 4.0.11+ds4+~cs11.25.27-4
    • 4.0.11+ds5+~cs11.25.27-1
    • 4.0.13+ds1+~2.0.1+~cs1.4.4-1
    • 4.1.3+ds1+~2.0.1+~0.15.3+~cs1.4.4-1
    • 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-1
    • 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-2
    • 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-3
    • 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-4
    • 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-5
    • 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-6
    • 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-7
    • 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-8
    • 4.4.1+ds1+~3.0.5+~0.16.6+~cs1.4.4-1
    • 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-1
    • 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-2
    • 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-3
    • 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4
    • 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-5
    • 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-6
    • 4.4.8+ds1+~3.1.0+~0.16.6+~cs1.4.4-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • jupyterlab Debian:14

    Softwareversionen
    • 4.0.11+ds1+~cs11.25.27-7
    • 4.0.11+ds1+~cs11.25.27-8
    • 4.0.11+ds1+~cs11.25.27-9
    • 4.0.11+ds2+~cs11.25.27-1
    • 4.0.11+ds2+~cs11.25.27-3
    • 4.0.11+ds3+~cs11.25.27-1
    • 4.0.11+ds4+~cs11.25.27-1
    • 4.0.11+ds4+~cs11.25.27-2
    • 4.0.11+ds4+~cs11.25.27-3
    • 4.0.11+ds4+~cs11.25.27-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.0.11+ds5+~cs11.25.27-1

    Auf 4.0.11+ds5+~cs11.25.27-1 aktualisieren

  • systeminformation npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 4.17.0, < 5.31.6

    Auf 5.31.6 aktualisieren

  • jupyterlab Ubuntu:25.10

    Softwareversionen
    • 4.0.11+ds1+~cs11.25.27-5
    • 4.0.11+ds1+~cs11.25.27-6
    • 4.0.11+ds1+~cs11.25.27-7
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • jupyterlab Ubuntu:26.10

    Softwareversionen
    • 4.0.11+ds1+~cs11.25.27-9
    • 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-3
    • 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-systeminformation Ubuntu:26.10

    Softwareversionen
    • 5.31.6-4
    • 5.31.7-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • jupyterlab Ubuntu:26.04:LTS

    Softwareversionen
    • 4.0.11+ds1+~cs11.25.27-7
    • 4.0.11+ds1+~cs11.25.27-8
    • 4.0.11+ds1+~cs11.25.27-9
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →