p PatchFirst

CVE-2026-46421

CVE-2026-46421 · Supply chain compromise via malicious package versions (@cap-js/sqlite, @cap-js/postgres, @cap-js/db-service)

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

The SAP Cloud Application Programming Model is a tool for building enterprise-grade cloud applications, and cap-js/cds-dbs is the monorepo for SQL database services for that tool. On April 29, 2026, compromised versions of `@cap-js/[email protected]`, `@cap-js/[email protected]`, and `@cap-js/[email protected]` were published. The malicious packages harvested credentials and attempted self-propagation. If a compromised version was installed, all credentials accessible on that machine (npm tokens, cloud provider credentials, SSH keys, GitHub PATs) should be considered compromised. User should upgrade to `@cap-js/sqlite` >= 2.4.0, `@cap-js/postgres` >= 2.3.0, `@cap-js/db-service` >= 2.11.0. If a compromised version was ever installed, rotate all affected credentials. No known workarounds are available.

CVSS 9.3 · Crítica · EPSS 0,5% · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • @cap-js/sqlite

    Versiones
    • = 2.2.2: Afectada

    Sin corrección publicada

  • @cap-js/postgres

    Versiones
    • = 2.2.2: Afectada

    Sin corrección publicada

  • @cap-js/db-service

    Versiones
    • = 2.10.1: Afectada

    Sin corrección publicada

  • @cap-js/sqlite npm

    Versiones
    • 2.2.2
    Intervalos de versiones afectados
    • SEMVER: ≥ 2.2.2, < 2.3.0

    Actualiza a 2.3.0

  • @cap-js/postgres npm

    Versiones
    • 2.2.2
    Intervalos de versiones afectados
    • SEMVER: ≥ 2.2.2, < 2.3.0

    Actualiza a 2.3.0

  • @cap-js/db-service npm

    Versiones
    • 2.10.1
    Intervalos de versiones afectados
    • SEMVER: ≥ 2.10.1, < 2.11.0

    Actualiza a 2.11.0

Fuentes originales

Comprueba tu servidor →