CVE-2026-46421
CVE-2026-46421 · Supply chain compromise via malicious package versions (@cap-js/sqlite, @cap-js/postgres, @cap-js/db-service)
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
The SAP Cloud Application Programming Model is a tool for building enterprise-grade cloud applications, and cap-js/cds-dbs is the monorepo for SQL database services for that tool. On April 29, 2026, compromised versions of `@cap-js/[email protected]`, `@cap-js/[email protected]`, and `@cap-js/[email protected]` were published. The malicious packages harvested credentials and attempted self-propagation. If a compromised version was installed, all credentials accessible on that machine (npm tokens, cloud provider credentials, SSH keys, GitHub PATs) should be considered compromised. User should upgrade to `@cap-js/sqlite` >= 2.4.0, `@cap-js/postgres` >= 2.3.0, `@cap-js/db-service` >= 2.11.0. If a compromised version was ever installed, rotate all affected credentials. No known workarounds are available.
CVSS 9.3 · Kritisch · EPSS 0,5% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: node
Betroffene Produkte und Versionen
@cap-js/sqlite
- Softwareversionen
- = 2.2.2: Betroffen
Keine Korrektur veröffentlicht
@cap-js/postgres
- Softwareversionen
- = 2.2.2: Betroffen
Keine Korrektur veröffentlicht
@cap-js/db-service
- Softwareversionen
- = 2.10.1: Betroffen
Keine Korrektur veröffentlicht
@cap-js/sqlite npm
- Softwareversionen
- 2.2.2
- Betroffene Versionsbereiche
- SEMVER: ≥ 2.2.2, < 2.3.0
Auf 2.3.0 aktualisieren
@cap-js/postgres npm
- Softwareversionen
- 2.2.2
- Betroffene Versionsbereiche
- SEMVER: ≥ 2.2.2, < 2.3.0
Auf 2.3.0 aktualisieren
@cap-js/db-service npm
- Softwareversionen
- 2.10.1
- Betroffene Versionsbereiche
- SEMVER: ≥ 2.10.1, < 2.11.0
Auf 2.11.0 aktualisieren