CVE-2026-46421
CVE-2026-46421 · Supply chain compromise via malicious package versions (@cap-js/sqlite, @cap-js/postgres, @cap-js/db-service)
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
The SAP Cloud Application Programming Model is a tool for building enterprise-grade cloud applications, and cap-js/cds-dbs is the monorepo for SQL database services for that tool. On April 29, 2026, compromised versions of `@cap-js/[email protected]`, `@cap-js/[email protected]`, and `@cap-js/[email protected]` were published. The malicious packages harvested credentials and attempted self-propagation. If a compromised version was installed, all credentials accessible on that machine (npm tokens, cloud provider credentials, SSH keys, GitHub PATs) should be considered compromised. User should upgrade to `@cap-js/sqlite` >= 2.4.0, `@cap-js/postgres` >= 2.3.0, `@cap-js/db-service` >= 2.11.0. If a compromised version was ever installed, rotate all affected credentials. No known workarounds are available.
CVSS 9.3 · Critique · EPSS 0,5% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: node
Produits et versions concernés
@cap-js/sqlite
- Versions du logiciel
- = 2.2.2: Concernée
Aucun correctif publié
@cap-js/postgres
- Versions du logiciel
- = 2.2.2: Concernée
Aucun correctif publié
@cap-js/db-service
- Versions du logiciel
- = 2.10.1: Concernée
Aucun correctif publié
@cap-js/sqlite npm
- Versions du logiciel
- 2.2.2
- Plages de versions concernées
- SEMVER: ≥ 2.2.2, < 2.3.0
Mettez à jour vers 2.3.0
@cap-js/postgres npm
- Versions du logiciel
- 2.2.2
- Plages de versions concernées
- SEMVER: ≥ 2.2.2, < 2.3.0
Mettez à jour vers 2.3.0
@cap-js/db-service npm
- Versions du logiciel
- 2.10.1
- Plages de versions concernées
- SEMVER: ≥ 2.10.1, < 2.11.0
Mettez à jour vers 2.11.0