p PatchFirst

CVE-2026-55697

CVE-2026-55697 · pnpm: Repository-controlled configDependencies can select a pacquet native install engine

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

pnpm is a package manager. Prior to 10.34.2 and 11.5.3, pnpm can install configDependencies declared in pnpm-workspace.yaml before command dispatch. Before the patch, a repository could declare pacquet or @pnpm/pacquet as a config dependency and pnpm treated that repository-controlled dependency as an install-engine opt-in. During install, pnpm resolved a platform-specific @pacquet/<platform>-<arch>/pacquet binary from node_modules/.pnpm-config/<packageName> and spawned it as the developer or CI user. This vulnerability is fixed in 10.34.2 and 11.5.3.

CVSS 7.5 · Alta · EPSS 0,2% · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • pnpm

    Versiones
    • < 10.34.2: Afectada
    • >= 11.0.0, < 11.5.3: Afectada

    Sin corrección publicada

  • pnpm npm

    Intervalos de versiones afectados
    • SEMVER: < 10.34.2

    Actualiza a 10.34.2

  • pnpm npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 11.0.0, < 11.5.3

    Actualiza a 11.5.3

Fuentes originales

Comprueba tu servidor →