p PatchFirst

CVE-2026-55697

CVE-2026-55697 · pnpm: Repository-controlled configDependencies can select a pacquet native install engine

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

pnpm is a package manager. Prior to 10.34.2 and 11.5.3, pnpm can install configDependencies declared in pnpm-workspace.yaml before command dispatch. Before the patch, a repository could declare pacquet or @pnpm/pacquet as a config dependency and pnpm treated that repository-controlled dependency as an install-engine opt-in. During install, pnpm resolved a platform-specific @pacquet/<platform>-<arch>/pacquet binary from node_modules/.pnpm-config/<packageName> and spawned it as the developer or CI user. This vulnerability is fixed in 10.34.2 and 11.5.3.

CVSS 7.5 · Hoch · EPSS 0,2% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • pnpm

    Softwareversionen
    • < 10.34.2: Betroffen
    • >= 11.0.0, < 11.5.3: Betroffen

    Keine Korrektur veröffentlicht

  • pnpm npm

    Betroffene Versionsbereiche
    • SEMVER: < 10.34.2

    Auf 10.34.2 aktualisieren

  • pnpm npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 11.0.0, < 11.5.3

    Auf 11.5.3 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →