p PatchFirst

CVE-2026-55697

CVE-2026-55697 · pnpm: Repository-controlled configDependencies can select a pacquet native install engine

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

pnpm is a package manager. Prior to 10.34.2 and 11.5.3, pnpm can install configDependencies declared in pnpm-workspace.yaml before command dispatch. Before the patch, a repository could declare pacquet or @pnpm/pacquet as a config dependency and pnpm treated that repository-controlled dependency as an install-engine opt-in. During install, pnpm resolved a platform-specific @pacquet/<platform>-<arch>/pacquet binary from node_modules/.pnpm-config/<packageName> and spawned it as the developer or CI user. This vulnerability is fixed in 10.34.2 and 11.5.3.

CVSS 7.5 · Élevée · EPSS 0,2% · Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • pnpm

    Versions du logiciel
    • < 10.34.2: Concernée
    • >= 11.0.0, < 11.5.3: Concernée

    Aucun correctif publié

  • pnpm npm

    Plages de versions concernées
    • SEMVER: < 10.34.2

    Mettez à jour vers 10.34.2

  • pnpm npm

    Plages de versions concernées
    • SEMVER: ≥ 11.0.0, < 11.5.3

    Mettez à jour vers 11.5.3

Sources originales

Vérifiez votre serveur →