CVE-2026-75508
CVE-2026-75508 · GraphQL-core: Denial of service via comment tokens bypassing the parser's max_tokens limit
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
GraphQL-core is a Python port of the GraphQL.js reference implementation. From 3.2.3 until 3.2.12 and 3.3.0rc1, the parser's max_tokens limit in Parser.advance_lexer counts only non-comment tokens returned after Lexer.lookahead skips comments. Each skipped comment is still allocated as a Token and retained through token.next and token.prev, allowing a highly compressible comment-padded GraphQL document to pass a low token limit while consuming memory. An unauthenticated remote attacker can exhaust worker memory before AST-based depth or complexity controls run. This issue is fixed in versions 3.2.12 and 3.3.0rc1.
CVSS 7.5 · Alta · EPSS 0,6% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
graphql-core
- Versiones
- >= 3.2.3, < 3.2.12: Afectada
- >= 3.3.0a3, < 3.3.0rc1: Afectada
Sin corrección publicada
graphql-core Debian:12
- Versiones
- 2.3.2-1
- 3.1.7-1
- 3.2.0-1
- 3.2.1-1
- 3.2.11-1
- 3.2.12-1
- 3.2.3-1
- 3.2.3-2
- 3.2.4-1
- 3.2.5-1
- 3.2.6-1
- 3.2.6-2
- 3.2.7-1
- 3.2.8-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
graphql-core Debian:13
- Versiones
- 3.2.11-1
- 3.2.12-1
- 3.2.6-1
- 3.2.6-2
- 3.2.7-1
- 3.2.8-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
graphql-core Debian:14
- Versiones
- 3.2.11-1
- 3.2.6-1
- 3.2.6-2
- 3.2.7-1
- 3.2.8-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.2.12-1
Actualiza a 3.2.12-1
graphql-core PyPI
- Versiones
- 3.2.10
- 3.2.11
- 3.2.3
- 3.2.4
- 3.2.5
- 3.2.6
- 3.2.7
- 3.2.8
- 3.2.9
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 3.2.3, < 3.2.12
Actualiza a 3.2.12
graphql-core PyPI
- Versiones
- 3.3.0a10
- 3.3.0a11
- 3.3.0a12
- 3.3.0a13
- 3.3.0a14
- 3.3.0a3
- 3.3.0a4
- 3.3.0a5
- 3.3.0a6
- 3.3.0a7
- 3.3.0a8
- 3.3.0a9
- 3.3.0b0
- 3.3.0b1
- 3.3.0b2
- 3.3.0rc0
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 3.3.0a3, < 3.3.0rc1
Actualiza a 3.3.0rc1
graphql-core Ubuntu:22.04:LTS
- Versiones
- 2.3.2-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
graphql-core Ubuntu:24.04:LTS
- Versiones
- 3.2.3-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
graphql-core Ubuntu:26.10
- Versiones
- 3.2.7-1
- 3.2.8-1
- 3.2.11-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
graphql-core Ubuntu:26.04:LTS
- Versiones
- 3.2.6-1
- 3.2.6-2
- 3.2.7-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/graphql-python/graphql-core/security/advisories/GHSA-r77w-qph3-7vf8
- https://github.com/graphql-python/graphql-core/commit/437dea102e92fdf05a2971ca76787c5a5bad875a
- https://github.com/graphql-python/graphql-core/commit/80ef435a1808fbbcc4aaac63ae76771a1c91002d
- https://github.com/graphql-python/graphql-core/releases/tag/v3.2.12
- https://github.com/graphql-python/graphql-core/releases/tag/v3.3.0rc1
- https://nvd.nist.gov/vuln/detail/CVE-2026-75508