p PatchFirst

CVE-2026-75508

CVE-2026-75508 · GraphQL-core: Denial of service via comment tokens bypassing the parser's max_tokens limit

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

GraphQL-core is a Python port of the GraphQL.js reference implementation. From 3.2.3 until 3.2.12 and 3.3.0rc1, the parser's max_tokens limit in Parser.advance_lexer counts only non-comment tokens returned after Lexer.lookahead skips comments. Each skipped comment is still allocated as a Token and retained through token.next and token.prev, allowing a highly compressible comment-padded GraphQL document to pass a low token limit while consuming memory. An unauthenticated remote attacker can exhaust worker memory before AST-based depth or complexity controls run. This issue is fixed in versions 3.2.12 and 3.3.0rc1.

CVSS 7.5 · Hoch · EPSS 0,6% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · python

Betroffene Produkte und Versionen

  • graphql-core

    Softwareversionen
    • >= 3.2.3, < 3.2.12: Betroffen
    • >= 3.3.0a3, < 3.3.0rc1: Betroffen

    Keine Korrektur veröffentlicht

  • graphql-core Debian:12

    Softwareversionen
    • 2.3.2-1
    • 3.1.7-1
    • 3.2.0-1
    • 3.2.1-1
    • 3.2.11-1
    • 3.2.12-1
    • 3.2.3-1
    • 3.2.3-2
    • 3.2.4-1
    • 3.2.5-1
    • 3.2.6-1
    • 3.2.6-2
    • 3.2.7-1
    • 3.2.8-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • graphql-core Debian:13

    Softwareversionen
    • 3.2.11-1
    • 3.2.12-1
    • 3.2.6-1
    • 3.2.6-2
    • 3.2.7-1
    • 3.2.8-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • graphql-core Debian:14

    Softwareversionen
    • 3.2.11-1
    • 3.2.6-1
    • 3.2.6-2
    • 3.2.7-1
    • 3.2.8-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.2.12-1

    Auf 3.2.12-1 aktualisieren

  • graphql-core PyPI

    Softwareversionen
    • 3.2.10
    • 3.2.11
    • 3.2.3
    • 3.2.4
    • 3.2.5
    • 3.2.6
    • 3.2.7
    • 3.2.8
    • 3.2.9
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 3.2.3, < 3.2.12

    Auf 3.2.12 aktualisieren

  • graphql-core PyPI

    Softwareversionen
    • 3.3.0a10
    • 3.3.0a11
    • 3.3.0a12
    • 3.3.0a13
    • 3.3.0a14
    • 3.3.0a3
    • 3.3.0a4
    • 3.3.0a5
    • 3.3.0a6
    • 3.3.0a7
    • 3.3.0a8
    • 3.3.0a9
    • 3.3.0b0
    • 3.3.0b1
    • 3.3.0b2
    • 3.3.0rc0
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 3.3.0a3, < 3.3.0rc1

    Auf 3.3.0rc1 aktualisieren

  • graphql-core Ubuntu:22.04:LTS

    Softwareversionen
    • 2.3.2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • graphql-core Ubuntu:24.04:LTS

    Softwareversionen
    • 3.2.3-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • graphql-core Ubuntu:26.10

    Softwareversionen
    • 3.2.7-1
    • 3.2.8-1
    • 3.2.11-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • graphql-core Ubuntu:26.04:LTS

    Softwareversionen
    • 3.2.6-1
    • 3.2.6-2
    • 3.2.7-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →