CVE-2026-75508
CVE-2026-75508 · GraphQL-core: Denial of service via comment tokens bypassing the parser's max_tokens limit
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
GraphQL-core is a Python port of the GraphQL.js reference implementation. From 3.2.3 until 3.2.12 and 3.3.0rc1, the parser's max_tokens limit in Parser.advance_lexer counts only non-comment tokens returned after Lexer.lookahead skips comments. Each skipped comment is still allocated as a Token and retained through token.next and token.prev, allowing a highly compressible comment-padded GraphQL document to pass a low token limit while consuming memory. An unauthenticated remote attacker can exhaust worker memory before AST-based depth or complexity controls run. This issue is fixed in versions 3.2.12 and 3.3.0rc1.
CVSS 7.5 · Élevée · EPSS 0,6% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · python
Produits et versions concernés
graphql-core
- Versions du logiciel
- >= 3.2.3, < 3.2.12: Concernée
- >= 3.3.0a3, < 3.3.0rc1: Concernée
Aucun correctif publié
graphql-core Debian:12
- Versions du logiciel
- 2.3.2-1
- 3.1.7-1
- 3.2.0-1
- 3.2.1-1
- 3.2.11-1
- 3.2.12-1
- 3.2.3-1
- 3.2.3-2
- 3.2.4-1
- 3.2.5-1
- 3.2.6-1
- 3.2.6-2
- 3.2.7-1
- 3.2.8-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
graphql-core Debian:13
- Versions du logiciel
- 3.2.11-1
- 3.2.12-1
- 3.2.6-1
- 3.2.6-2
- 3.2.7-1
- 3.2.8-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
graphql-core Debian:14
- Versions du logiciel
- 3.2.11-1
- 3.2.6-1
- 3.2.6-2
- 3.2.7-1
- 3.2.8-1
- Plages de versions concernées
- ECOSYSTEM: < 3.2.12-1
Mettez à jour vers 3.2.12-1
graphql-core PyPI
- Versions du logiciel
- 3.2.10
- 3.2.11
- 3.2.3
- 3.2.4
- 3.2.5
- 3.2.6
- 3.2.7
- 3.2.8
- 3.2.9
- Plages de versions concernées
- ECOSYSTEM: ≥ 3.2.3, < 3.2.12
Mettez à jour vers 3.2.12
graphql-core PyPI
- Versions du logiciel
- 3.3.0a10
- 3.3.0a11
- 3.3.0a12
- 3.3.0a13
- 3.3.0a14
- 3.3.0a3
- 3.3.0a4
- 3.3.0a5
- 3.3.0a6
- 3.3.0a7
- 3.3.0a8
- 3.3.0a9
- 3.3.0b0
- 3.3.0b1
- 3.3.0b2
- 3.3.0rc0
- Plages de versions concernées
- ECOSYSTEM: ≥ 3.3.0a3, < 3.3.0rc1
Mettez à jour vers 3.3.0rc1
graphql-core Ubuntu:22.04:LTS
- Versions du logiciel
- 2.3.2-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
graphql-core Ubuntu:24.04:LTS
- Versions du logiciel
- 3.2.3-2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
graphql-core Ubuntu:26.10
- Versions du logiciel
- 3.2.7-1
- 3.2.8-1
- 3.2.11-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
graphql-core Ubuntu:26.04:LTS
- Versions du logiciel
- 3.2.6-1
- 3.2.6-2
- 3.2.7-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
Sources originales
- https://github.com/graphql-python/graphql-core/security/advisories/GHSA-r77w-qph3-7vf8
- https://github.com/graphql-python/graphql-core/commit/437dea102e92fdf05a2971ca76787c5a5bad875a
- https://github.com/graphql-python/graphql-core/commit/80ef435a1808fbbcc4aaac63ae76771a1c91002d
- https://github.com/graphql-python/graphql-core/releases/tag/v3.2.12
- https://github.com/graphql-python/graphql-core/releases/tag/v3.3.0rc1
- https://nvd.nist.gov/vuln/detail/CVE-2026-75508