p PatchFirst

CVE-2026-9358

CVE-2026-9358 · postcss-selector-parser AST Serialization container.js toString recursion

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

A vulnerability was determined in postcss-selector-parser up to 6.1.2/7.1.2. Affected is the function toString of the file src/selectors/container.js of the component AST Serialization. Executing a manipulation can lead to uncontrolled recursion. It is possible to launch the attack remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 6.1.3 and 7.1.3 is able to address this issue. This patch is called 5bc698cef66f8abd12610dc623e5d67cbc0f869d. It is suggested to upgrade the affected component. The vendor explains, that according to his definition "DoS on server-side on user-generated CSS is low risk for us (since most users compile own CSS with PostCSS)." The commits were backported to 6.x branch, which was the most downloaded version.

CVSS 5.3 · Media · EPSS 0,3% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · node

Productos y versiones afectados

  • postcss-selector-parser

    Versiones
    • 6.1.0: Afectada
    • 6.1.1: Afectada
    • 6.1.2: Afectada
    • 7.1.0: Afectada
    • 7.1.1: Afectada
    • 7.1.2: Afectada
    • 6.1.3: No afectada
    • 7.1.3: No afectada

    Actualiza a 6.1.3; Actualiza a 7.1.3

  • node-css-loader Debian:12

    Versiones
    • 6.11.0+~cs15.5.7-1
    • 6.11.0+~cs15.5.7-2
    • 6.11.0+~cs15.5.7-3
    • 6.7.2+~cs14.0.11-1
    • 6.8.1+~cs14.0.17-1
    • 6.8.1+~cs14.0.17-2
    • 6.8.1+~cs14.1.4-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-css-loader Debian:13

    Versiones
    • 6.11.0+~cs15.5.7-1
    • 6.11.0+~cs15.5.7-2
    • 6.11.0+~cs15.5.7-3
    • 6.8.1+~cs14.0.17-1
    • 6.8.1+~cs14.0.17-2
    • 6.8.1+~cs14.1.4-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-css-loader Debian:14

    Versiones
    • 6.8.1+~cs14.0.17-1
    • 6.8.1+~cs14.0.17-2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 6.8.1+~cs14.1.4-1

    Actualiza a 6.8.1+~cs14.1.4-1

  • postcss-selector-parser npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 6.1.0, < 6.1.3

    Actualiza a 6.1.3

  • postcss-selector-parser npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 7.1.0, < 7.1.3

    Actualiza a 7.1.3

  • node-css-loader Ubuntu:20.04:LTS

    Versiones
    • 1.0.1-1
    • 1.0.1+repack-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-css-loader Ubuntu:22.04:LTS

    Versiones
    • 5.0.1+~cs14.0.5-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-css-loader Ubuntu:24.04:LTS

    Versiones
    • 6.7.2+~cs14.0.11-1
    • 6.8.1+~cs14.0.17-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-css-loader Ubuntu:25.10

    Versiones
    • 6.8.1+~cs14.0.17-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-css-loader Ubuntu:26.10

    Versiones
    • 6.8.1+~cs14.0.17-2
    • 6.8.1+~cs14.1.4-1
    • 6.11.0+~cs15.5.7-1
    • 6.11.0+~cs15.5.7-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-css-loader Ubuntu:26.04:LTS

    Versiones
    • 6.8.1+~cs14.0.17-1
    • 6.8.1+~cs14.0.17-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →