p PatchFirst

CVE-2026-9358

CVE-2026-9358 · postcss-selector-parser AST Serialization container.js toString recursion

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

A vulnerability was determined in postcss-selector-parser up to 6.1.2/7.1.2. Affected is the function toString of the file src/selectors/container.js of the component AST Serialization. Executing a manipulation can lead to uncontrolled recursion. It is possible to launch the attack remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 6.1.3 and 7.1.3 is able to address this issue. This patch is called 5bc698cef66f8abd12610dc623e5d67cbc0f869d. It is suggested to upgrade the affected component. The vendor explains, that according to his definition "DoS on server-side on user-generated CSS is low risk for us (since most users compile own CSS with PostCSS)." The commits were backported to 6.x branch, which was the most downloaded version.

CVSS 5.3 · Mittel · EPSS 0,3% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • postcss-selector-parser

    Softwareversionen
    • 6.1.0: Betroffen
    • 6.1.1: Betroffen
    • 6.1.2: Betroffen
    • 7.1.0: Betroffen
    • 7.1.1: Betroffen
    • 7.1.2: Betroffen
    • 6.1.3: Nicht betroffen
    • 7.1.3: Nicht betroffen

    Auf 6.1.3 aktualisieren; Auf 7.1.3 aktualisieren

  • node-css-loader Debian:12

    Softwareversionen
    • 6.11.0+~cs15.5.7-1
    • 6.11.0+~cs15.5.7-2
    • 6.11.0+~cs15.5.7-3
    • 6.7.2+~cs14.0.11-1
    • 6.8.1+~cs14.0.17-1
    • 6.8.1+~cs14.0.17-2
    • 6.8.1+~cs14.1.4-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-css-loader Debian:13

    Softwareversionen
    • 6.11.0+~cs15.5.7-1
    • 6.11.0+~cs15.5.7-2
    • 6.11.0+~cs15.5.7-3
    • 6.8.1+~cs14.0.17-1
    • 6.8.1+~cs14.0.17-2
    • 6.8.1+~cs14.1.4-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-css-loader Debian:14

    Softwareversionen
    • 6.8.1+~cs14.0.17-1
    • 6.8.1+~cs14.0.17-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 6.8.1+~cs14.1.4-1

    Auf 6.8.1+~cs14.1.4-1 aktualisieren

  • postcss-selector-parser npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 6.1.0, < 6.1.3

    Auf 6.1.3 aktualisieren

  • postcss-selector-parser npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 7.1.0, < 7.1.3

    Auf 7.1.3 aktualisieren

  • node-css-loader Ubuntu:20.04:LTS

    Softwareversionen
    • 1.0.1-1
    • 1.0.1+repack-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-css-loader Ubuntu:22.04:LTS

    Softwareversionen
    • 5.0.1+~cs14.0.5-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-css-loader Ubuntu:24.04:LTS

    Softwareversionen
    • 6.7.2+~cs14.0.11-1
    • 6.8.1+~cs14.0.17-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-css-loader Ubuntu:25.10

    Softwareversionen
    • 6.8.1+~cs14.0.17-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-css-loader Ubuntu:26.10

    Softwareversionen
    • 6.8.1+~cs14.0.17-2
    • 6.8.1+~cs14.1.4-1
    • 6.11.0+~cs15.5.7-1
    • 6.11.0+~cs15.5.7-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-css-loader Ubuntu:26.04:LTS

    Softwareversionen
    • 6.8.1+~cs14.0.17-1
    • 6.8.1+~cs14.0.17-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →