CVE-2026-9358
CVE-2026-9358 · postcss-selector-parser AST Serialization container.js toString recursion
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A vulnerability was determined in postcss-selector-parser up to 6.1.2/7.1.2. Affected is the function toString of the file src/selectors/container.js of the component AST Serialization. Executing a manipulation can lead to uncontrolled recursion. It is possible to launch the attack remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 6.1.3 and 7.1.3 is able to address this issue. This patch is called 5bc698cef66f8abd12610dc623e5d67cbc0f869d. It is suggested to upgrade the affected component. The vendor explains, that according to his definition "DoS on server-side on user-generated CSS is low risk for us (since most users compile own CSS with PostCSS)." The commits were backported to 6.x branch, which was the most downloaded version.
CVSS 5.3 · Medium · EPSS 0.3% · Fix available
- Published
- Updated
Affected products and versions
postcss-selector-parser
- Versions
- 6.1.0: Affected
- 6.1.1: Affected
- 6.1.2: Affected
- 7.1.0: Affected
- 7.1.1: Affected
- 7.1.2: Affected
- 6.1.3: Not affected
- 7.1.3: Not affected
Update to 6.1.3; Update to 7.1.3
node-css-loader Debian:12
- Versions
- 6.11.0+~cs15.5.7-1
- 6.11.0+~cs15.5.7-2
- 6.11.0+~cs15.5.7-3
- 6.7.2+~cs14.0.11-1
- 6.8.1+~cs14.0.17-1
- 6.8.1+~cs14.0.17-2
- 6.8.1+~cs14.1.4-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-css-loader Debian:13
- Versions
- 6.11.0+~cs15.5.7-1
- 6.11.0+~cs15.5.7-2
- 6.11.0+~cs15.5.7-3
- 6.8.1+~cs14.0.17-1
- 6.8.1+~cs14.0.17-2
- 6.8.1+~cs14.1.4-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-css-loader Debian:14
- Versions
- 6.8.1+~cs14.0.17-1
- 6.8.1+~cs14.0.17-2
- Affected ranges
- ECOSYSTEM: < 6.8.1+~cs14.1.4-1
Update to 6.8.1+~cs14.1.4-1
postcss-selector-parser npm
- Affected ranges
- SEMVER: ≥ 6.1.0, < 6.1.3
Update to 6.1.3
postcss-selector-parser npm
- Affected ranges
- SEMVER: ≥ 7.1.0, < 7.1.3
Update to 7.1.3
node-css-loader Ubuntu:20.04:LTS
- Versions
- 1.0.1-1
- 1.0.1+repack-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-css-loader Ubuntu:22.04:LTS
- Versions
- 5.0.1+~cs14.0.5-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-css-loader Ubuntu:24.04:LTS
- Versions
- 6.7.2+~cs14.0.11-1
- 6.8.1+~cs14.0.17-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-css-loader Ubuntu:25.10
- Versions
- 6.8.1+~cs14.0.17-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-css-loader Ubuntu:26.10
- Versions
- 6.8.1+~cs14.0.17-2
- 6.8.1+~cs14.1.4-1
- 6.11.0+~cs15.5.7-1
- 6.11.0+~cs15.5.7-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-css-loader Ubuntu:26.04:LTS
- Versions
- 6.8.1+~cs14.0.17-1
- 6.8.1+~cs14.0.17-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://vuldb.com/vuln/365321
- https://vuldb.com/vuln/365321/cti
- https://vuldb.com/cve/CVE-2026-9358
- https://vuldb.com/submit/813080
- https://gist.github.com/bx33661/581e3a38134601c04e19b4dfc9b459b9
- https://github.com/postcss/postcss-selector-parser/commit/5bc698cef66f8abd12610dc623e5d67cbc0f869d
- https://github.com/postcss/postcss-selector-parser/releases/tag/7.1.3
- https://nvd.nist.gov/vuln/detail/CVE-2026-9358