p PatchFirst

CVE-2019-5421

CVE-2019-5421

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Plataformatec Devise version 4.5.0 and earlier, using the lockable module contains a CWE-367 vulnerability in The `Devise::Models::Lockable` class, more specifically at the `#increment_failed_attempts` method. File location: lib/devise/models/lockable.rb that can result in Multiple concurrent requests can prevent an attacker from being blocked on brute force attacks. This attack appear to be exploitable via Network connectivity - brute force attacks. This vulnerability appears to have been fixed in 4.6.0 and later.

CVSS 9.8 · Crítica · EPSS 1,6% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • devise ruby gem

    Versiones
    • 4.5.0 and earlier using the lockable module: Afectada

    Sin corrección publicada

  • ruby-devise Debian:12

    Intervalos de versiones afectados
    • ECOSYSTEM: < 4.5.0-3

    Actualiza a 4.5.0-3

  • gitlab Ubuntu:16.04:LTS

    Versiones
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • ruby-devise Ubuntu:18.04:LTS

    Versiones
    • 4.2.0-1
    • 4.3.0-1
    • 4.4.3-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • ruby-devise Ubuntu:20.04:LTS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 4.5.0-3

    Actualiza a 4.5.0-3

Fuentes originales

Comprueba tu servidor →