p PatchFirst

CVE-2021-35940

CVE-2021-35940 · Regression of CVE-2017-12613

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

An out-of-bounds array read in the apr_time_exp*() functions was fixed in the Apache Portable Runtime 1.6.3 release (CVE-2017-12613). The fix for this issue was not carried forward to the APR 1.7.x branch, and hence version 1.7.0 regressed compared to 1.6.3 and is vulnerable to the same issue.

CVSS 7.1 · Alta · EPSS 1,2% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • apache portable runtime (apr)

    Versiones
    • Apache Portable Runtime 1.7.0: Afectada

    Sin corrección publicada

  • apr Debian:12

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.7.0-7

    Actualiza a 1.7.0-7

  • apr Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.7.0-7

    Actualiza a 1.7.0-7

  • apr Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.7.0-7

    Actualiza a 1.7.0-7

  • apr Ubuntu:Pro:14.04:LTS

    Versiones
    • 1.4.8-1ubuntu1
    • 1.4.8-2
    • 1.4.8-3
    • 1.5.0-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.5.0-1ubuntu0.1~esm1

    Actualiza a 1.5.0-1ubuntu0.1~esm1

  • apr Ubuntu:Pro:16.04:LTS

    Versiones
    • 1.5.2-3
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.5.2-3ubuntu0.1~esm1

    Actualiza a 1.5.2-3ubuntu0.1~esm1

  • apr Ubuntu:22.04:LTS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.7.0-6ubuntu1

    Actualiza a 1.7.0-6ubuntu1

Fuentes originales

Comprueba tu servidor →