p PatchFirst

GHSA-3wqh-h42r-x8fq

GHSA-3wqh-h42r-x8fq · Denial of Service in @hapi/content

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Versions of `@hapi/content` prior to 4.1.1 and 5.0.1 are vulnerable to Denial of Service. The Content-Encoding HTTP header parser has a vulnerability which will cause the function to throw a system error if the header contains some invalid values. Because hapi rethrows system errors (as opposed to catching expected application errors), the error is thrown all the way up the stack. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services. ## Recommendation Upgrade to version 5.0.2. Versions 4.1.1 and 5.0.1 are fixed but only available for direct download through the repository.

Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • @hapi/content npm

    Intervalos de versiones afectados
    • SEMVER: < 5.0.2

    Actualiza a 5.0.2

Fuentes originales

Comprueba tu servidor →