p PatchFirst

GHSA-3wqh-h42r-x8fq

GHSA-3wqh-h42r-x8fq · Denial of Service in @hapi/content

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Versions of `@hapi/content` prior to 4.1.1 and 5.0.1 are vulnerable to Denial of Service. The Content-Encoding HTTP header parser has a vulnerability which will cause the function to throw a system error if the header contains some invalid values. Because hapi rethrows system errors (as opposed to catching expected application errors), the error is thrown all the way up the stack. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services. ## Recommendation Upgrade to version 5.0.2. Versions 4.1.1 and 5.0.1 are fixed but only available for direct download through the repository.

Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • @hapi/content npm

    Plages de versions concernées
    • SEMVER: < 5.0.2

    Mettez à jour vers 5.0.2

Sources originales

Vérifiez votre serveur →