GHSA-3wqh-h42r-x8fq
GHSA-3wqh-h42r-x8fq · Denial of Service in @hapi/content
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Versions of `@hapi/content` prior to 4.1.1 and 5.0.1 are vulnerable to Denial of Service. The Content-Encoding HTTP header parser has a vulnerability which will cause the function to throw a system error if the header contains some invalid values. Because hapi rethrows system errors (as opposed to catching expected application errors), the error is thrown all the way up the stack. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services. ## Recommendation Upgrade to version 5.0.2. Versions 4.1.1 and 5.0.1 are fixed but only available for direct download through the repository.
Fix available
- Published
- Updated
Stack: node
Affected products and versions
@hapi/content npm
- Affected ranges
- SEMVER: < 5.0.2
Update to 5.0.2