p PatchFirst

GHSA-r5xw-q988-826m

GHSA-r5xw-q988-826m · Remote Memory Exposure in mongoose

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Versions of `mongoose` before 4.3.6, 3.8.39 are vulnerable to remote memory exposure. Trying to save a number to a field of type Buffer on the affected mongoose versions allocates a chunk of uninitialized memory and stores it in the database. ## Recommendation Update to version 4.3.6, 3.8.39 or later.

CVSS 5.1 · Media · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • mongoose npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 3.5.5, < 3.8.39

    Actualiza a 3.8.39

  • mongoose npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 4.0.0, < 4.3.6

    Actualiza a 4.3.6

Fuentes originales

Comprueba tu servidor →