p PatchFirst

GHSA-r5xw-q988-826m

GHSA-r5xw-q988-826m · Remote Memory Exposure in mongoose

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Versions of `mongoose` before 4.3.6, 3.8.39 are vulnerable to remote memory exposure. Trying to save a number to a field of type Buffer on the affected mongoose versions allocates a chunk of uninitialized memory and stores it in the database. ## Recommendation Update to version 4.3.6, 3.8.39 or later.

CVSS 5.1 · Mittel · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • mongoose npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 3.5.5, < 3.8.39

    Auf 3.8.39 aktualisieren

  • mongoose npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 4.0.0, < 4.3.6

    Auf 4.3.6 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →