p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de org.apache.spark:spark-core_2.10

Vulnerabilidades publicadas para org.apache.spark:spark-core_2.10 en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 3

  1. CVE-2022-31777

    Media · CVSS 5.4EPSS 1,82%Sin corrección publicada

    Apache Spark XSS vulnerability in log viewer UI Javascript

    A stored cross-site scripting (XSS) vulnerability in Apache Spark 3.2.1 and earlier, and 3.3.0, allows remote attackers to execute arbitrary JavaScript in the web browser of a user, by including a malicious payload into the logs which would be returned in logs rendered in the UI.

    Publicación Actualización
  2. CVE-2018-1334

    Media · CVSS 6EPSS 0,51%Corrección disponible

    CVE-2018-1334

    In Apache Spark 1.0.0 to 2.1.2, 2.2.0 to 2.2.1, and 2.3.0, when using PySpark or SparkR, it's possible for a different local user to connect to the Spark application and impersonate the user running the Spark application.

    • Actualiza a 2.1.3
    • Actualiza a 2.2.2
    Publicación Actualización
  3. CVE-2017-12612

    Alta · CVSS 8.5EPSS 0,73%Corrección disponible

    CVE-2017-12612

    In Apache Spark 1.6.0 until 2.1.1, the launcher API performs unsafe deserialization of data received by its socket. This makes applications launched programmatically using the launcher API potentially vulnerable to arbitrary code execution by an attacker with access to any user account on the local machine. It does not affect apps run by spark-submit or spark-shell. The attacker would be able to execute code as the user that ran the Spark application. Users are encouraged to update to version 2.2.0 or later.

    • Actualiza a 2.1.2
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →