p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in org.apache.spark:spark-core_2.10

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für org.apache.spark:spark-core_2.10: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 3

  1. CVE-2022-31777

    Mittel · CVSS 5.4EPSS 1,82%Keine Korrektur veröffentlicht

    Apache Spark XSS vulnerability in log viewer UI Javascript

    A stored cross-site scripting (XSS) vulnerability in Apache Spark 3.2.1 and earlier, and 3.3.0, allows remote attackers to execute arbitrary JavaScript in the web browser of a user, by including a malicious payload into the logs which would be returned in logs rendered in the UI.

    Veröffentlicht Aktualisiert
  2. CVE-2018-1334

    Mittel · CVSS 6EPSS 0,51%Korrektur verfügbar

    CVE-2018-1334

    In Apache Spark 1.0.0 to 2.1.2, 2.2.0 to 2.2.1, and 2.3.0, when using PySpark or SparkR, it's possible for a different local user to connect to the Spark application and impersonate the user running the Spark application.

    • Auf 2.1.3 aktualisieren
    • Auf 2.2.2 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2017-12612

    Hoch · CVSS 8.5EPSS 0,73%Korrektur verfügbar

    CVE-2017-12612

    In Apache Spark 1.6.0 until 2.1.1, the launcher API performs unsafe deserialization of data received by its socket. This makes applications launched programmatically using the launcher API potentially vulnerable to arbitrary code execution by an attacker with access to any user account on the local machine. It does not affect apps run by spark-submit or spark-shell. The attacker would be able to execute code as the user that ran the Spark application. Users are encouraged to update to version 2.2.0 or later.

    • Auf 2.1.2 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →