p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de org.apache.spark:spark-core_2.10

Vulnérabilité publiée pour org.apache.spark:spark-core_2.10 au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 3

  1. CVE-2022-31777

    Moyenne · CVSS 5.4EPSS 1,82%Aucun correctif publié

    Apache Spark XSS vulnerability in log viewer UI Javascript

    A stored cross-site scripting (XSS) vulnerability in Apache Spark 3.2.1 and earlier, and 3.3.0, allows remote attackers to execute arbitrary JavaScript in the web browser of a user, by including a malicious payload into the logs which would be returned in logs rendered in the UI.

    Publication Mise à jour
  2. CVE-2018-1334

    Moyenne · CVSS 6EPSS 0,51%Correctif disponible

    CVE-2018-1334

    In Apache Spark 1.0.0 to 2.1.2, 2.2.0 to 2.2.1, and 2.3.0, when using PySpark or SparkR, it's possible for a different local user to connect to the Spark application and impersonate the user running the Spark application.

    • Mettez à jour vers 2.1.3
    • Mettez à jour vers 2.2.2
    Publication Mise à jour
  3. CVE-2017-12612

    Élevée · CVSS 8.5EPSS 0,73%Correctif disponible

    CVE-2017-12612

    In Apache Spark 1.6.0 until 2.1.1, the launcher API performs unsafe deserialization of data received by its socket. This makes applications launched programmatically using the launcher API potentially vulnerable to arbitrary code execution by an attacker with access to any user account on the local machine. It does not affect apps run by spark-submit or spark-shell. The attacker would be able to execute code as the user that ran the Spark application. Users are encouraged to update to version 2.2.0 or later.

    • Mettez à jour vers 2.1.2
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →