p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de deepseek-tui

Vulnerabilidades publicadas para deepseek-tui en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 11

  1. CVE-2026-75915

    Alta · CVSS 8.7EPSS 0,68%Corrección disponible

    CodeWhale before 0.8.64 Environment Variable Leak via js_execution

    CodeWhale versions before 0.8.64 contain an environment variable exposure vulnerability in the js_execution tool that fails to scrub parent process environment variables before spawning Node.js. Attackers can craft malicious JavaScript code executed by the tool to read process.env and leak API keys, cloud credentials, and authentication tokens back to the model context.

    • Actualiza a 0.8.41
    Publicación Actualización
  2. CVE-2026-75914

    Alta · CVSS 8.7EPSS 0,53%Corrección disponible

    CodeWhale before 0.8.64 Path Traversal via image_analyze symlink

    CodeWhale versions before 0.8.64 contain a path traversal vulnerability in the image_analyze tool that fails to canonicalize symlinks before reading files. Attackers can create workspace symlinks pointing to external files with image extensions to leak file bytes to the vision endpoint without user approval.

    • Actualiza a 0.8.41
    Publicación Actualización
  3. CVE-2026-75913

    Alta · CVSS 8.5EPSS 0,48%Corrección disponible

    CodeWhale before 0.8.64 Argument Injection via git_show

    CodeWhale versions >= 0.3.27 and < 0.8.64 (published as deepseek-tui >= 0.3.27 and < 0.8.41 on npm and 0.3.27 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain an argument injection vulnerability in the git_show tool. The model-supplied rev parameter is passed unvalidated into the git show argv without an --end-of-options sentinel, so a value beginning with --output= is interpreted as a git flag. Because the tool is registered as auto-approved and advertised as read-only, an attacker (via a malicious repository combined with prompt injection) can cause an unprompted arbitrary file write at the privi

    • Actualiza a 0.8.41
    Publicación Actualización
  4. CVE-2026-75912

    Alta · CVSS 8.3EPSS 0,45%Corrección disponible

    CodeWhale before 0.8.64 Argument Injection via git_blame

    CodeWhale versions before 0.8.64 contain an argument injection vulnerability in the git_blame tool that allows attackers to read arbitrary files by injecting git options into the unvalidated rev parameter. Attackers can supply rev values like --contents=/path/to/file to exfiltrate sensitive files such as SSH keys and credentials through the tool output returned to the model.

    • Actualiza a 0.8.41
    Publicación Actualización
  5. CVE-2026-75911

    Alta · CVSS 8.5EPSS 0,25%Corrección disponible

    CodeWhale before 0.8.64 Remote Code Execution via allow_shell

    CodeWhale versions before 0.8.64 fail to properly validate the allow_shell configuration parameter from project config files, allowing attackers to enable arbitrary shell command execution by committing a malicious .codewhale/config.toml file to a repository. When a user clones and opens the repository in CodeWhale, the AI model gains access to exec_shell and task_shell tools, enabling execution of arbitrary shell commands on the victim's machine without explicit user consent.

    • Actualiza a 0.8.41
    Publicación Actualización
  6. CVE-2026-75859

    Alta · CVSS 8.7EPSS 0,53%Corrección disponible

    CodeWhale before 0.8.64 Arbitrary File Read via instructions

    CodeWhale versions before 0.8.64 fail to validate file paths in the project config instructions field, allowing attackers to read arbitrary files on the victim's system. A malicious .codewhale/config.toml file in a cloned repository can specify paths outside the workspace that are read and injected into the AI system prompt for exfiltration.

    • Actualiza a 0.8.41
    Publicación Actualización
  7. CVE-2026-75858

    Alta · CVSS 8.5EPSS 0,36%Corrección disponible

    CodeWhale rlm_eval before 0.8.64 Remote Code Execution

    CodeWhale (packages codewhale / codewhale-tui) versions >= 0.8.41 and < 0.8.64 contain a remote code execution vulnerability in the rlm_eval tool. The tool's approval_requirement() returns ApprovalRequirement::Auto, which the engine treats as 'never prompt,' causing arbitrary model-supplied Python code to run in a python3 interpreter without consulting the user's configured --approval-policy and without any approval prompt or audit step. An attacker can induce the agent to execute arbitrary code via prompt injection in untrusted content the agent reads (a web page, fetched URL, repository file, or MCP tool result); the companion rlm_open tool

    • Actualiza a 0.8.41
    Publicación Actualización
  8. CVE-2026-75857

    Alta · CVSS 7.3EPSS 0,15%Corrección disponible

    CodeWhale before 0.8.64 Privilege Escalation via exec_shell_interact

    CodeWhale versions >= 0.3.10 and < 0.8.64 (published as deepseek-tui >= 0.3.10 and < 0.8.41 on npm and 0.3.10 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain a vulnerability in the exec_shell_interact (alias exec_interact) tool, whose approval_requirement returns ApprovalRequirement::Auto. This overrides the default Required approval for code-executing tools, so LLM-controlled stdin is written into an already-approved long-running interactive shell (e.g., a python3 -i REPL, mysql, ssh, or sudo -i session) without any approval prompt. An attacker who can inject instructions via untrusted content th

    • Actualiza a 0.8.41
    Publicación Actualización
  9. CVE-2026-75856

    Crítica · CVSS 9.2EPSS 0,5%Corrección disponible

    CodeWhale before 0.8.64 SSRF Bypass via DNS Pinning TOCTOU

    CodeWhale before 0.8.64 contains a server-side request forgery bypass vulnerability in DNS pinning logic that fails to prevent time-of-check-time-of-use attacks. Attackers can manipulate DNS responses to fail initial resolution checks and succeed on secondary requests, allowing requests to internal IP addresses and bypassing SSRF mitigations.

    • Actualiza a 0.8.41
    Publicación Actualización
  10. CVE-2026-45311

    Crítica · CVSS 9.6EPSS 0,57%Corrección disponible

    CodeWhale: run_tests Tool Enables RCE via Malicious Repository Without Approval

    CodeWhale is a DeepSeek + MiMo coding agent in terminal. From 0.3.0 to 0.8.23, the run_tests tool executes cargo test in the workspace with ApprovalRequirement::Auto, meaning it runs without any user approval prompt. cargo test compiles and executes arbitrary code: test binaries, build.rs build scripts, and proc macros. While auto-approving test execution is a deliberate design choice, it creates an inconsistency in the security boundary. However, in a malicious repository, test code can execute arbitrary shell commands, exfiltrate credentials, or establish persistence with zero approval. The attack is amplified by AGENTS.md (auto-loaded into

    • Actualiza a 0.8.23
    Publicación Actualización
  11. CVE-2026-45310

    Alta · CVSS 7.4EPSS 0,28%Corrección disponible

    CodeWhale: SSRF via HTTP Redirect Bypass in fetch_url Tool

    CodeWhale is a DeepSeek + MiMo coding agent in terminal. Prior to 0.8.22, the fetch_url tool validates the initial URL's resolved IP address against a restricted-IP blocklist (is_restricted_ip()) to prevent SSRF attacks against internal services (cloud metadata endpoints, localhost, private networks). However, the HTTP client (reqwest) is configured to automatically follow up to 5 redirects (reqwest::redirect::Policy::limited(5)) without re-validating the redirect target against the same SSRF protections. This vulnerability is fixed in 0.8.22.

    • Actualiza a 0.8.22
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →