p PatchFirst

CVE-2026-75913

CVE-2026-75913 · CodeWhale before 0.8.64 Argument Injection via git_show

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

CodeWhale versions >= 0.3.27 and < 0.8.64 (published as deepseek-tui >= 0.3.27 and < 0.8.41 on npm and 0.3.27 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain an argument injection vulnerability in the git_show tool. The model-supplied rev parameter is passed unvalidated into the git show argv without an --end-of-options sentinel, so a value beginning with --output= is interpreted as a git flag. Because the tool is registered as auto-approved and advertised as read-only, an attacker (via a malicious repository combined with prompt injection) can cause an unprompted arbitrary file write at the privilege of the invoking user, targeting sensitive files such as ~/.ssh/authorized_keys, ~/.bashrc, or ~/.gitconfig. Fixed in codewhale / codewhale-tui 0.8.64 by adding rev validation; the deprecated deepseek-tui crate has no fixed release.

CVSS 8.5 · Alta · EPSS 0,5% · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • codewhale

    Versiones
    • ≥ 0.3.27, ≤ 0.8.41: Afectada (semver)

    Sin corrección publicada

  • codewhale

    Versiones
    • ≥ 0.3.27, < 0.8.41: Afectada (semver)
    • 0.8.41: No afectada (semver)

    Actualiza a 0.8.41

  • codewhale

    Versiones
    • ≥ 0.8.41, < 0.8.64: Afectada (semver)
    • 0.8.64: No afectada (semver)

    Actualiza a 0.8.64

  • deepseek-tui crates.io

    Intervalos de versiones afectados
    • SEMVER: ≥ 0.3.27, ≤ 0.8.41

    Sin corrección publicada

  • deepseek-tui npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 0.3.27, < 0.8.41

    Actualiza a 0.8.41

  • codewhale-tui crates.io

    Intervalos de versiones afectados
    • SEMVER: ≥ 0.8.41, < 0.8.64

    Actualiza a 0.8.64

  • codewhale npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 0.8.41, < 0.8.64

    Actualiza a 0.8.64

Fuentes originales

Comprueba tu servidor →